PAT--1030 Travel Plan (30 分)

本文深入探讨了旅行者如何利用地图上的距离和成本信息来决定从起点到目的地的最短路径,特别是在路径不唯一时,选择总成本最低的路径。通过Dijkstra算法结合深度优先搜索(DFS),程序能够找到并输出这一最优路径及其总距离和成本。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40
#include<bits/stdc++.h>
using namespace std;
const int INF = 100000;
const int MAXN = 1000;
int G[MAXN][MAXN],cost[MAXN][MAXN];
int vis[MAXN];
int n,m,s,ed;
int d[MAXN];
vector<int> pre[MAXN];
vector<int> path,tmpPath;
int minValue = INF;

void Dijstra(int s)
{
    fill(d,d+MAXN,INF);
    d[s] = 0;

    for(int i=0; i<n; i++)
    {
        int u=-1,MIN = INF;

        for(int j=0; j<n; j++)
        {
            if(vis[j]==false && d[j]<MIN)
            {
                MIN = d[j];
                u = j;
            }
        }
        if(u==-1)
            return;

        vis[u] = true;
        for(int v=0; v<n; v++)
        {
            if(vis[v]==false && G[u][v]!=INF)
            {
                if(d[u]+G[u][v]<d[v])
                {
                    d[v] = d[u]+G[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                }
                else if(d[u]+G[u][v]==d[v])
                {
                    pre[v].push_back(u);
                }

            }
        }
    }
}

void DFS(int v)
{
    if(v==s)
    {
        tmpPath.push_back(s);
        int value=0;
        for(int i = tmpPath.size()-1; i>0; i--)
        {
            int id = tmpPath[i],idNext = tmpPath[i-1];
            value+=cost[id][idNext];
        }
        if(value<minValue)
        {
            minValue = value;
            path = tmpPath;
        }
        tmpPath.pop_back();
        return;
    }

    //递归式
    tmpPath.push_back(v);
    for(int i=0; i<pre[v].size(); i++)
    {
        DFS(pre[v][i]);
    }
    tmpPath.pop_back();
}
int main()
{
    cin>>n>>m>>s>>ed;
    memset(vis,0,sizeof(vis));
    fill(G[0],G[0]+MAXN*MAXN,INF);
    int a,b,c,f;
    //cin>>a>>b>>c>>f;
    for(int i=0; i<m; i++)
    {
        cin>>a>>b>>c>>f;
        G[a][b] = G[b][a] = c;
        cost[a][b] = cost[b][a] = f;
    }

    Dijstra(s);
    DFS(ed);

    int gValue = 0;
    for(int i=path.size()-1; i>=0; i--)
    {
        cout<<path[i];
        cout<<" ";
        if(i!=0){
            gValue += G[path[i]][path[i-1]];
        }
    }

    cout<<gValue<<" "<<minValue<<endl;
    return 0;
}

 Dijstra+DFS

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值