HDU 1.3.3 排名

Problem Description

今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑 
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的 
考生,并将他们的成绩按降序打印。 

 


 

Input

测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N 
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一 
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号 
(题目号由1到M)。 
当读入的考生人数为0时,输入结束,该场考试不予处理。 

 


 

Output

对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高 
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考 
号的升序输出。 

 


 

Sample Input

4 5 2510 10 12 13 15CS004 3 5 1 3CS003 5 2 4 1 3 5CS002 2 1 2CS001 3 2 3 51 2 4010 30CS001 1 22 3 2010 10 10CS000000000000000001 0CS000000000000000002 2 1 20

 


 

Sample Output

3CS003 60CS001 37CS004 3701CS000000000000000002 20

Hint
Huge input, scanf is recommended.

 


 

 

Source

浙大计算机研究生复试上机考试-2005年

 


 

Recommend

JGShining

#include<stdio.h>  
#include<string>  
#include"algorithm"  
using namespace std;  
#define MAXM 10  
#define MAXN 1000  
#define MAXID 21  
struct Student  
{  
    char ID[MAXID];  
    int slove[MAXN];  
    int point;  
    int slvNum;  
};  
Student stu[MAXN];  
int proPoint[MAXM];  
int cmp(const Student &a, const Student &b)  
{  
    if (a.point == b.point)  
        return strcmp(a.ID, b.ID) > 0 ? 0 : 1;  
    else  
        return a.point > b.point;  
}  
int main()  
{  
    //freopen("f://in.txt", "r", stdin);  
    //freopen("f://out.txt", "w", stdout);  
    int n, proNum, minPoint;  
    while (scanf("%d", &n)!=EOF && n != 0)  
    {  
        scanf("%d %d", &proNum, &minPoint);  
        memset(proPoint, 0, sizeof(proPoint));  
        memset(stu, 0, sizeof(stu));  
        for (int i = 0; i < proNum; i++)  
            scanf("%d", &proPoint[i]);  
        int count = 0;  
        for (int i = 0; i < n; i++)  
        {  
            scanf("%s %d", stu[i].ID, &stu[i].slvNum);  
            stu[i].point = 0;  
            for (int j = 0; j < stu[i].slvNum;j++)  
            {  
                scanf("%d", &stu[i].slove[j]);  
                stu[i].point += proPoint[stu[i].slove[j]-1];  
            }  
            if (stu[i].point >= minPoint)  
                count++;  
        }  
        sort(stu, stu + n, cmp);  
        printf("%d\n", count);  
        for (int i = 0; i < count; i++)  
        {  
            printf("%s %d\n", stu[i].ID, stu[i].point);  
        }  
    }  
    return 0;  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值