本博客与RayXXZhang的博客保持同步更新,转载请注明来自RayXXZhang的博客-POJ1003解题报告
题目概览
标题
Hangover
要求
Time Limit: 1000MS
Memory Limit: 10000K
题目描述
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We’re assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + … + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.
输入
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
输出
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
输入示例
1.00
3.71
0.04
5.19
0.00
输出示例
3 card(s)
61 card(s)
1 card(s)
273 card(s)
解题报告
分析
本题较简单,可以采用map+vector的方式提高效率,vector用于保存原始的数据顺序,map可以根据数据大小自动排序。
在计算的时候可以将每一步的计算结果与map的迭代器里的数比较,如果符合,则将取出map中的下一个数,这样能仅进行一遍计算就能得到全部结果。
最后输出的时候键的顺序采用vector里保存的顺序(即原始顺序),值则采用map中的值。
源码
#include<map>
#include<vector>
#include<string>
#include<iostream>
using namespace std;
int main() {
string item;
vector<double> input;
map<double, int> sorted;
double num;
while (true) {
cin >> item;
if (item == "0.00") {
break;
}
num = item[0] - '0' + (item[2] - '0') * 0.1 + (item[3] - '0') * 0.01;
input.push_back(num);
sorted.insert(make_pair(num, 0));
}
double result = 0;
map<double, int>::iterator it = sorted.begin();
for (int i = 2; it != sorted.end(); ++i) {
result += 1.0 / i;
while (result > it->first) {
it->second = i - 1;
++it;
if (it == sorted.end()) {
break;
}
}
}
for (vector<double>::iterator itv = input.begin(); itv != input.end(); ++itv) {
cout << sorted[*itv] << " card(s)" << endl;
}
}