The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed.
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO
YES
/*
用到了回溯和减枝
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
const int maxn = 10;
int vis[maxn][maxn];
char str[maxn][maxn];
int n, m, T, s_x, s_y, e_x, e_y;
bool flag;
int d[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};
bool check(int x, int y){
if(x >= 0 && x < n && y >= 0 && y < m)
return true;
else return false;
}
void DFS(int x, int y, int t){
if (str[x][y] == 'D' && t == T){
flag = true;
return;
}
vis[x][y] = 1;
// 奇偶减枝
int temp = T - t - (abs(x-e_x)+abs(y-e_y));
// 总时间 要求时间 已用时间 最短距离所用时间
if(temp < 0 || (temp & 1)) return;
//如果temp小于0证明当前时间无法到达 return
//如果temp为奇数是不可能的 return
for (int i = 0; i < 4; i++){
int dx = x + d[i][0];
int dy = y + d[i][1];
if (check(dx, dy) && !vis[dx][dy] && str[dx][dy] != 'X'){
DFS(dx, dy, t+1);
//回溯
if (flag) return;
vis[dx][dy] = 0;
}
}
}
int main()
{
while (scanf ("%d %d %d", &n, &m, &T) != EOF && (n || m || T)){
for (int i = 0; i < n; i++){
scanf ("%s", str[i]);
}
memset(vis, 0, sizeof(vis));
flag = false;
for (int i = 0; i < n; i++)
for (int j = 0; j < m; j++){
if (str[i][j] == 'S')
s_x = i, s_y = j;
if (str[i][j] == 'D')
e_x = i, e_y = j;
}
DFS (s_x, s_y, 0);
if (flag) printf ("YES\n");
else printf ("NO\n");
}
return 0;
}
/*
把矩阵看成如下形式:
0 1 0 1 0 1
1 0 1 0 1 0
0 1 0 1 0 1
1 0 1 0 1 0
0 1 0 1 0 1
从为 0 的格子走一步,必然走向为 1 的格子 。
从为 1 的格子走一步,必然走向为 0 的格子 。
即:
从 0 走向 1 必然是奇数步,从 0 走向 0 必然是偶数步。
所以当遇到从 0 走向 0 但是要求时间是奇数的或者
从 1 走向 0 但是要求时间是偶数的,都可以直接判断不可达!
比如一张地图c
S...
....
....
....
...D
要求从S点到达D点,此时,从S到D的最短距离为s = abs ( dx - sx ) + abs ( dy - sy )。
如果地图中出现了不能经过的障碍物:
S..X
XX.X
...X
.XXX
...D
此时的最短距离s' = s + 4,为了绕开障碍,不管偏移几个点,偏移的距离都是最短距离s加上一个偶数距离。
就如同上面说的矩阵,要求你从0走到0,无论你怎么绕,永远都是最短距离(偶数步)加上某个偶数步;
要求你从1走到0,永远只能是最短距离(奇数步)加上某个偶数步。
*/