Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 4888 | Accepted: 3062 |
Description
Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.
Given this data, tell FJ the exact ordering of the cows.
Input
* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.
Output
Sample Input
5 1 2 1 0
Sample Output
2 4 5 3 1
水过去的代码,200多MS
#include<stdio.h>
#include<string.h>
int a[8005],b[8005];
bool f[8005];
int main()
{
int n,c,j;
while(scanf("%d",&n)!=EOF)
{
memset(f,false,sizeof(f));
for(int i=2;i<=n;i++) scanf("%d",&a[i]);
a[1]=0;
for(int i=n;i>=1;i--)
{
c=a[i]+1;
int k=0;
for(j=1;j<=n;j++)
{
if(!f[j]) k++;
if(k==c) break;
}
b[i]=j;
f[j]=true;
}
for(int i=1;i<=n;i++)
printf("%d/n",b[i]);
}
return 0;
}
线段树 50多MS
#include <stdlib.h>
#include <iostream>
#include <stdio.h>
using namespace std;
#define L 10000
struct node
{
int l,r,c;
} T[L*3];
int a[L],b[L];
void tree(int u,int l,int r)
{
T[u].c=r-l+1;
T[u].l=l;
T[u].r=r;
if(r==l)return;
int t=(r+l)>>1;
tree(u+u,l,t);
tree(u+u+1,t+1,r);
}
int find(int u,int pos)
{
while(1)
{
T[u].c--;
if(T[u].l==T[u].r)return T[u].l;
int u2=u<<1;
if(T[u2].c>=pos)
{
u=u2;
}
else
{
pos-=T[u2].c;
u=u2+1;
}
}
}
int main()
{
int i, j, n;
while(cin>>n)
{
a[1]=0;
for(i=2; i<=n; i++) scanf("%d",&a[i]);
tree(1,1,n);
for(i=n; i>=1; i--)
b[i]=find(1,a[i]+1);
for(i=1; i<=n; i++)printf("%d/n",b[i]);
}
return 0;
}