迷宫问题
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 11216 | Accepted: 6709 |
Description
定义一个二维数组:
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, };
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0 0 1 0 1 0 0 0 0 0 0 0 1 1 1 0 0 0 0 1 0
Sample Output
(0, 0) (1, 0) (2, 0) (2, 1) (2, 2) (2, 3) (2, 4) (3, 4) (4, 4)
#include <cstdio>
#include <cstring>
#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
#include <stack>
#define maxn 10
using namespace std;
int map[maxn][maxn];
bool vis[maxn][maxn];
int dir[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};
struct node{
int x, y, perx, pery;
};
node path[maxn][maxn];
node st, ed;
void putpath(int x, int y){
stack<node>p;
node now = path[x][y];
while(1){
p.push(now);
if(now.x == 0 && now.y == 0)
break;
now = path[now.perx][now.pery];
}
while(!p.empty()){
now = p.top();
p.pop();
printf("(%d, %d)\n", now.x, now.y);
}
}
bool check(node a){
if(a.x < 0 || a.x > 4 || a.y < 0 || a.y > 4 || map[a.x][a.y] == 1)
return 0;
return 1;
}
void bfs(){
memset(vis, 0 ,sizeof(vis));
queue<node>q;
st.x = 0, st.y = 0;
q.push(st);
vis[0][0] = 1;
while(!q.empty()){
st = q.front();
q.pop();
if(st.x == 4 && st.y == 4){
path[st.x][st.y] = st;
break;
}
for(int i = 0; i < 4; ++i){
ed.x = st.x + dir[i][0];
ed.y = st.y + dir[i][1];
if(check(ed) && !vis[ed.x][ed.y]){
vis[ed.x][ed.y] = 1;
ed.perx = st.x;
ed.pery = st.y;
path[ed.x][ed.y] = ed;
q.push(ed);
}
}
}
}
int main (){
for(int i = 0; i < 5; ++i)
for(int j = 0; j < 5; ++j){
scanf("%d",&map[i][j]);
}
bfs();
putpath(4, 4);
return 0;
}