POJ 3984--迷宫问题【BFS && 记录路径】

本文介绍了一种解决迷宫问题的方法,通过使用广度优先搜索(BFS)算法找到从迷宫左上角到右下角的最短路径。文章提供了一个具体的5x5迷宫示例,并给出了完整的C++代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11216 Accepted: 6709

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

#include <cstdio>
#include <cstring>
#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
#include <stack>
#define maxn 10
using namespace std;

int map[maxn][maxn];
bool vis[maxn][maxn];
int dir[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};
struct node{
    int x, y, perx, pery;
};

node path[maxn][maxn];
node st, ed;
void putpath(int x, int y){
    stack<node>p;
    node now = path[x][y];
    while(1){
        p.push(now);
        if(now.x == 0 && now.y == 0)
            break;
        now = path[now.perx][now.pery];
    }
    while(!p.empty()){
        now = p.top();
        p.pop();
        printf("(%d, %d)\n", now.x, now.y);
    }
}

bool check(node a){
    if(a.x < 0 || a.x > 4 || a.y < 0 || a.y > 4 || map[a.x][a.y] == 1)
        return 0;
    return 1;
}

void bfs(){
    memset(vis, 0 ,sizeof(vis));
    queue<node>q;
    st.x = 0, st.y = 0;
    q.push(st);
    vis[0][0] = 1;
    while(!q.empty()){
        st = q.front();
        q.pop();
        if(st.x == 4 && st.y == 4){
            path[st.x][st.y] = st;
            break;
        }
        for(int i = 0; i < 4; ++i){
            ed.x = st.x + dir[i][0];
            ed.y = st.y + dir[i][1];
            if(check(ed) && !vis[ed.x][ed.y]){
                vis[ed.x][ed.y] = 1;
                ed.perx = st.x;
                ed.pery = st.y;
                path[ed.x][ed.y] = ed;
                q.push(ed);
            }
         }
    }
}

int main (){
    for(int i = 0; i < 5; ++i)
    for(int j = 0; j < 5; ++j){
        scanf("%d",&map[i][j]);
    }
    bfs();
    putpath(4, 4);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值