HDU 1097 a hard puzzle

本文介绍了一个高效的方法来计算两个整数a和b的幂次运算的最后一位数字,通过观察规律和使用取模操作简化计算。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
  
  
7 66 8 800
 

Sample Output
  
  
9

6

简单来说,就是求前一个数的最后一个数的b次方的问题,很容易就看出来有规律,四个一循环,所以很容易就解决了。

#include<stdio.h>
#include<math.h>
int main()
{
	int a,b,a1,b1,sum;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		a1=a%10;
		b1=b%4;
		if(b1==0){
			sum=((int)pow(a1,4))%10;
	     	printf("%d\n",sum);
		}
		else{
			sum=((int)pow(a1,b1))%10;
	     	printf("%d\n",sum);
		} 
	}
 } 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值