1102 Invert a Binary Tree (25分) 树的遍历 层序和中序遍历

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

 题目大意:

给出一棵树的所有点,输出此树的所有点交换左子树和右子树后的层序和中序遍历。

 吾:

#include <iostream>
#include <vector>
#include <string>	
#include <queue>

using namespace std;

int n;
vector<int> in, level;

struct node
{
	int lkid=-1, rkid=-1;
};

vector<node> v(n);
queue<int> q;
void levelorder(int root)
{

	
	int top = q.front();
	level.push_back(top);
	q.pop();
	
	if (v[top].rkid!=-1)
	{
		q.push(v[top].rkid);
	}
	if (v[top].lkid != -1)
	{
		q.push(v[top].lkid);
	}
	if (!q.empty())
	{
		levelorder(q.front());
	}
}

void inorder(int root)
{
	if (v[root].rkid!=-1)
	{
		inorder(v[root].rkid);
	}
	in.push_back(root);
	if (v[root].lkid!=-1)
	{
		inorder(v[root].lkid);
	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	scanf("%d\n", &n);
	v.resize(n);
	vector<bool> visit(n, false);
	for (int i = 0; i < n; i++)
	{
		string l, r;
		cin >> l >> r;
		if (l!="-")
		{
			v[i].lkid = stoi(l);
			visit[stoi(l)] = true;
		}
		if (r!="-")
		{
			v[i].rkid = stoi(r);
			visit[stoi(r)] = true;
		}
	}
	int root = 0;
	while (visit[root])
	{
		root++;
	}
	q.push(root);
	levelorder(root);
	cout << level[0];
	for (int i = 1; i < level.size(); i++)
	{
		cout << " " << level[i];
	}
	cout << endl;
	inorder(root);
	cout << in[0];
	for (int i = 1; i < in.size(); i++)
	{
		cout << " " << in[i];
	}
	cout << endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值