In this problem, we consider a simple programming language that has only declarations of onedimensional integer arrays and assignment statements. The problem is to find a bug in the given program.
The syntax of this language is given in BNF as follows:
〈program〉 ::= 〈declaration〉|〈program〉〈declaration〉|〈program〉〈assignment〉
〈declaration〉 ::= 〈array name〉 [〈number〉]〈new line〉
〈assignment〉 ::= 〈array name〉 [〈expression〉]= 〈expression〉〈newline〉
〈expression〉 ::= 〈number〉|〈array name〉 [〈expression〉]
〈number〉 ::= 〈digit〉|〈digit positive〉〈digit string〉
〈digit string〉 ::= 〈digit〉|〈digit〉〈digit string〉
〈digit positive〉 ::= 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
〈digit〉 ::= 0 | 〈digit positive〉
〈array name〉 ::= a | b | c | d | e | f | g | h | i | j | k | l | m |
n | o | p | q | r | s | t | u | v | w | x | y | z |
A | B | C | D | E | F | G | H | I | J | K | L | M |
N | O | P | Q | R | S | T | U | V | W | X | Y | Z
where 〈new line〉 denotes a new line character (LF).
Characters used in a program are alphabetical letters, decimal digits, =, [, ] and new line characters.
No other characters appear in a program.
A declaration declares an array and specifies its length. Valid indices of an array of length n are
integers between 0 and n − 1, inclusive. Note that the array names are case sensitive, i.e. array a and
array A are different arrays. The initial value of each element in the declared array is undefined.
For example, array a of length 10 and array b of length 5 are declared respectively as follows.
a[10]
b[5]
An expression evaluates to a non-negative integer. A 〈number〉 is interpreted as a decimal integer.
An 〈array name〉 [〈expression〉] evaluates to the value of the 〈expression〉-th element of the array.
An assignment assigns the value denoted by the right hand side to the array element specified by the
left hand side.
Examples of assignments are as follows.
a[0]=3
a[1]=0
a[2]=a[a[1]]
a[a[0]]=a[1]
A program is executed from the first line, line by line. You can assume that an array is declared
once and only
once before any of its element is assigned or referred to.
Given a program, you are requested to find the following bugs.
• An index of an array is invalid.
• An array element that has not been assigned before is referred to in an assignment as an index
of array or as the value to be assigned.
You can assume that other bugs, such as syntax errors, do not appear. You can also assume that
integers represented by 〈number〉s are between 0 and 231 − 1 (= 2147483647), inclusive.
Input
The input consists of multiple datasets followed by a line which contains only a single ‘.’ (period).
Each dataset consists of a program also followed by a line which contains only a single ‘.’ (period).
A program does not exceed 1000 lines. Any line does not exceed 80 characters excluding a new line
character.
Output
For each program in the input, you should answer the line number of the assignment in which the first
bug appears. The line numbers start with 1 for each program. If the program does not have a bug,
you should answer zero. The output should not contain extra characters such as spaces.
Sample Input
a[3]
a[0]=a[1]
.
x[1]
x[0]=x[0]
.
a[0]
a[0]=1
.
b[2]
b[0]=2
b[1]=b[b[0]]
b[0]=b[1]
.
g[2]
G[10]
g[0]=0
g[1]=G[0]
.
a[2147483647]
a[0]=1
B[2]
B[a[0]]=2
a[B[a[0]]]=3
a[2147483646]=a[2]
.
.
Sample Output
2
2
2
3
4
0
#include<bits/stdc++.h>
using namespace std;
struct Array{
int siz;
map<int,int>values;
void init(int sz){
siz=sz;
values.clear();
}
Array(){remov();}
void remov(){siz=-1;values.clear();}
bool exists(){return siz>=0;}
bool getValue(int idx,int &v){
if(values.count(idx)){
v=values[idx];
return true;
}
return false;
}
bool setValue(int idx,int v){
if(idx>=siz) return false;
values[idx]=v;
return true;
}
}arrays[128];
bool eval(const char* s,int &v){
if(isdigit(s[0])){
sscanf(s,"%d",&v);return true;
}
char a=s[0];
Array& ary=arrays[a];
if(!ary.exists()) return false;
int idx;
if(!eval(s+2,idx)) return false;
return ary.getValue(idx,v);
}
int main(){
//freopen("datain.txt","r",stdin);
char line[128];
int lineNum=0,bugLine=0;
while(scanf("%s",line)==1){
int expLen=strlen(line);
if(line[0]=='.'){
if(lineNum)printf("%d\n",bugLine);
for(int i=0;i<128;i++) arrays[i].remov();
lineNum=0;
bugLine=0;
continue;
}
if(bugLine>0)continue;
const char * pEq=strchr(line,'=');
if(pEq){
Array& ary=arrays[line[0]];
int rv,index,lLen=pEq-line;
if(ary.exists()&&eval(pEq+1,rv)&&eval(line+2,index)&&ary.setValue(index,rv))
lineNum++;
else bugLine=lineNum+1;
} else{
char name;int sz;
sscanf(line,"%c[%d]",&name,&sz);
arrays[name].init(sz);
lineNum++;
}
}
}