http://acm.hdu.edu.cn/showproblem.php?pid=3308
Total Submission(s): 6448 Accepted Submission(s): 2799
LCIS
Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6448 Accepted Submission(s): 2799
Problem Description
Given n integers.
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
Input
T in the first line, indicating the case number.
Each case starts with two integers n , m(0<n,m<=10 5).
The next line has n integers(0<=val<=10 5).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=10 5)
OR
Q A B(0<=A<=B< n).
Each case starts with two integers n , m(0<n,m<=10 5).
The next line has n integers(0<=val<=10 5).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=10 5)
OR
Q A B(0<=A<=B< n).
Output
For each Q, output the answer.
Sample Input
1 10 10 7 7 3 3 5 9 9 8 1 8 Q 6 6 U 3 4 Q 0 1 Q 0 5 Q 4 7 Q 3 5 Q 0 2 Q 4 6 U 6 10 Q 0 9
Sample Output
1 1 4 2 3 1 2 5
分析:典型的区间合并题目,是入门必做的区间合并类……
在构建的时候,需要同时构造包括左端点的区间lx、包括右端点的区间rx以及该区间的总的长度mx……在更新的时候需要判断在端点处的值是否符合递增……
当符合的时候,把左孩子和右孩子的LCIS整合起来,更新mx;当不符合时mx取lx和rx中的最大值。
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <map>
#include <cmath>
#include <vector>
using namespace std;
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define inf 0x3f3f3f3f
const int maxn= 100000+7;
typedef long long ll;
int lx[maxn<<2],mx[maxn<<2],rx[maxn<<2];
int a[maxn];
void pushup(int rt,int l,int r) {
int len = r-l+1;
int m = r+l>>1;
lx[rt] = lx[rt<<1];
rx[rt] = rx[rt<<1|1];
if((lx[rt] == (len-(len>>1))) && (a[m] < a[m+1]))lx[rt] += lx[rt<<1|1];
if((rx[rt] == (len>>1)) && (a[m] < a[m+1]))rx[rt] += rx[rt<<1];
mx[rt] = max(max(mx[rt<<1],mx[rt<<1|1]),(a[m] < a[m+1])?rx[rt<<1]+lx[rt<<1|1]:0);
}
void build(int l,int r,int rt) {
if(l == r) {
scanf("%d",&a[l]);
lx[rt] = mx[rt] = rx[rt] = 1;
return;
}
int mid = l+r>>1;
build(lson);
build(rson);
pushup(rt,l,r);
}
void update(int pos,int w,int l,int r,int rt) {
if(l == r) {
a[l] = w;
lx[rt] = rx[rt] = mx[rt] = 1;
return;
}
int mid = l+r>>1;
if(pos <= mid)update(pos,w,lson);
else update(pos,w,rson);
pushup(rt,l,r);
}
int query(int L,int R,int l,int r,int rt) {
if(L <= l && r <= R)
return mx[rt];
int mid = l+r>>1;
if(R <= mid)return query(L,R,lson);
else if(L > mid)return query(L,R,rson);
else {
int ltmp = query(L,mid,lson);
int rtmp = query(mid+1,R,rson);
int sum = 0;
if(a[mid+1] > a[mid]) {
sum = min(mid-L+1,rx[rt<<1])+min(R-mid,lx[rt<<1|1]);
}
return max(sum,max(ltmp,rtmp));
}
}
int main() {
// freopen("in.txt","r",stdin);
// freopen("out.txt","w",stdout);
int n,m,b,c,t;
char ss[10];
scanf("%d",&t);
while(t--) {
scanf("%d%d",&n,&m);
build(0,n-1,1);
for(int i = 1; i <= m; i++) {
scanf("%s%d%d",ss,&b,&c);
if(ss[0] == 'U') {
update(b,c,0,n-1,1);
} else {
printf("%d\n",query(b,c,0,n-1,1));
}
}
}
return 0;
}