C - 4-adjacent
Time limit : 2sec / Memory limit : 256MB
Score : 400 points
Problem Statement
We have a sequence of length N, a=(a1,a2,…,aN). Each ai is a positive integer.
Snuke's objective is to permute the element in a so that the following condition is satisfied:
- For each 1≤i≤N−1, the product of ai and ai+1 is a multiple of 4.
Determine whether Snuke can achieve his objective.
Constraints
- 2≤N≤105
- ai is an integer.
- 1≤ai≤109
Input
Input is given from Standard Input in the following format:
N
a1 a2 … aN
Output
If Snuke can achieve his objective, print Yes
; otherwise, print No
.
Sample Input 1
3
1 10 100
Sample Output 1
Yes
One solution is (1,100,10).
Sample Input 2
4
1 2 3 4
Sample Output 2
No
It is impossible to permute a so that the condition is satisfied.
Sample Input 3
3
1 4 1
Sample Output 3
Yes
The condition is already satisfied initially.
Sample Input 4
2
1 1
Sample Output 4
No
Sample Input 5
6
2 7 1 8 2 8
Sample Output 5
Yes
#include<bits/stdc++.h>
using namespace std;
int n, t, f, z;
int main()
{
t = 0; f = 0; z = 0;
scanf("%d", &n);
for(int i = 0; i < n; i++)
{
int a;
scanf("%d", &a);
if(a % 4 == 0) f++;
else if(a % 2 == 0) t++;
else z++;
}
int tmp = f - z;
if(tmp >= 0) printf("Yes\n");
else if(tmp == -1 && t == 0) printf("Yes\n");
else printf("No\n");
return 0;
}