PKU-1014 Dividing (多重背包)

本文探讨如何使用多重背包问题解决公平分配不同价值物品的挑战。通过输入描述的物品数量和价值,输出是否可以公平分配给两个接收者,使得每个接收者的总价值相等。该文提供了一个算法解决方案,并通过实例演示了实现过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

原题链接 http://poj.org/problem?id=1014

Dividing

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000.
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

Source Code

/*
此题可以用多重背包问题方法求解,其中包的容量为总量的一半,
各个物品的cost为i, weight为1, 且该物品有count[i]个,要求完全装满
*/  

#include <iostream>
using namespace std;

#define INF 1000000

//V指背包的最大容量
int result[60004],V;

//01背包
void ZeroOnePack(int cost, int weight)
{
	for(int i = V; i >= cost; i--)
		if(result[i] < result[i-cost]+weight)
			result[i] = result[i-cost]+weight;
}

//完全背包
void CompletePack(int cost, int weight)
{
	for(int i = cost; i <= V; i++)
		if(result[i] < result[i-cost]+weight)
			result[i] = result[i-cost]+weight;
}

//多重背包
void MultiplePack(int cost, int weight, int count)
{
	if(cost * count >= V)
		CompletePack(cost,weight);
	else
	{
		//采进二进制思想压缩,转化为01背包(13=1+2+4+6,即1,2,4,……,count-2^k+1)
		int k = 1;
		while(k < count)
		{
			ZeroOnePack(k*cost, k*weight);
			count -= k;
			k*=2;
		}
		ZeroOnePack(count*cost, count*weight);
	}
	
}


int main()
{
	int count[10];
	int i, collection;
	collection = 1;
	while(scanf("%d %d %d %d %d %d",&count[1], &count[2], 
		&count[3], &count[4], &count[5], &count[6])!=EOF)
	{
		if (count[1] == 0 && count[2] == 0 && count[3] == 0 &&
			count[4] == 0 && count[5] == 0 && count[6] == 0){
			break;
		}		
		
		printf("Collection #%d:\n", collection ++);

		//要求完全放满,初始化result[0]为0,其它全为负无穷
		for (i = 0; i < 60004; i++) {
			result[i] = -1 * INF;
		}
		result[0] = 0;
		V = 0;

		for (i = 1; i <= 6; i++) {
			V += (i * count[i]);
		}

		//总量是奇数不可分
		if (V % 2 == 1) {
			printf("Can't be divided.\n\n");
			continue;
		}

		V = V / 2;

		for(i = 1; i <= 6 ; i++)
			MultiplePack(i, 1, count[i]);
			
		if (result[V] < 0) {
			printf("Can't be divided.\n\n");
		} else {
			printf("Can be divided.\n\n");
		}	
	}
	
}	
内容概要:该论文研究了一种基于行波理论的输电线路故障诊断方法。当输电线路发生故障时,故障点会产生向两侧传播的电流和电压行波。通过相模变换对三相电流行波解耦,利用解耦后独立模量间的关系确定故障类型和相别,再采用小波变换模极大值法标定行波波头,从而计算故障点距离。仿真结果表明,该方法能准确识别故障类型和相别,并对故障点定位具有高精度。研究使用MATLAB进行仿真验证,为输电线路故障诊断提供了有效解决方案。文中详细介绍了三相电流信号生成、相模变换(Clarke变换)、小波变换波头检测、故障诊断主流程以及结果可视化等步骤,并通过多个实例验证了方法的有效性和准确性。 适合人群:具备一定电力系统基础知识和编程能力的专业人士,特别是从事电力系统保护与控制领域的工程师和技术人员。 使用场景及目标:①适用于电力系统的故障检测与诊断;②能够快速准确地识别输电线路的故障类型、相别及故障点位置;③为电力系统的安全稳定运行提供技术支持,减少停电时间和损失。 其他说明:该方法不仅在理论上进行了深入探讨,还提供了完整的Python代码实现,便于读者理解和实践。此外,文中还讨论了行波理论的核心公式、三相线路行波解耦、行波测距实现等关键技术点,并针对工程应用给出了注意事项,如波速校准、采样率要求、噪声处理等。这使得该方法不仅具有学术价值,也具有很强的实际应用前景。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值