数据结构实验之链表四:有序链表的归并
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Sample Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Sample Output
1 14 21 23 26 28 45 50 66 99 100
Hint
不得使用数组!
Source
#include <stdio.h>
#include <stdlib.h>
struct node
{
int a;
struct node *next;
};
struct node *creat(int n);
struct node *merge(struct node *head1, struct node *head2);
void display(struct node *head);
int main()
{
int m, n;
struct node *head1, *head2, *head;
scanf("%d%d", &m, &n);
head1=creat(m);
head2=creat(n);
head=merge(head1, head2);
display(head);
return 0;
}
struct node *creat(int n)
{
struct node *head, *p, *tail;
int i;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d", &p->a);
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
};
struct node *merge(struct node *head1, struct node *head2)
{
struct node *p1, *p2, *tail;
p1=head1->next;
p2=head2->next;
head1->next=NULL;
tail=head1;
free(head2);
while(p1&&p2)
{
if(p1->a<p2->a)
{
tail->next=p1;
tail=p1;
p1=p1->next;
tail->next=NULL;
}
else
{
tail->next=p2;
tail=p2;
p2=p2->next;
tail->next=NULL;
}
}
if(p1)
{
tail->next=p1;
}
else
{
tail->next=p2;
}
return head1;
}
void display(struct node *head)
{
struct node *p;
p=head->next;
while(p!=NULL)
{
if(p->next == NULL)
{
printf("%d\n", p->a);
}
else
{
printf("%d ", p->a);
}
p=p->next;
}
}