poj3254 状态压缩dp-Corn Fields

这是一道关于状态压缩动态规划的问题,描述了农民John在一个MxN的牧场上选择种植玉米的策略。John需要避免在相邻的地块上种植,包括不种植也是一种选择。题目要求计算所有可能的种植方案数量,并对结果取模100,000,000。输入包含牧场的行数和每行的肥沃情况,输出是可行的种植方案总数。题解指出,可以使用2的12次方来表示每行的所有状态,并通过状态转移方程求解。" 104846258,9287930,TeamViewer连接移动设备控制面板指南,"['远程桌面', '移动设备', 'TeamViewer教程', '远程协助', '技术指南']

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output
Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint
Number the squares as follows:

1 2 3
4

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题意:


在n*m的土地上种玉米,1对应的土地可以种,0对应的土地不可以种,两个玉米地不能上下左右相邻,问有多少种种法。注意可以不种!


题解:


一道状态压缩dp的问题,可以先网上了解一下状态压缩dp。
每一行最多12个,那么最多用2的12次方就可以表示每一行的所有状态。
(1)对于每一行的状态j,满足j&(j-1) == 0
(2)对于相邻两行的状态j、k,满足(j&k)==0
(3)dp[i][j]表示第i行处于j状态时的方法数,状态转移式为:
dp[i][num[j]] += sum(dp[i-1][num[k]]);


#include <iostream>
#include <string.h>
#include <cmath>
#define MAXN 4100
using namespace std;

int m,n;
int top;
int a[13];
int num[MAXN];
int dp[13][MAXN];

int isok(int x)
{
    if(x&(x<<1))
        return 0;
    return 1;
}

void cal(int n)
{
    top = 0;
    for(int i = 0; i < (1<<n); i++)
    {
        if(isok(i))
            num[top++] = i;
    }
}

int main()
{
    int b;
    while(cin >> m >> n)
    {
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        cal(n);
        for(int i = 1; i <= m; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                cin>>b;
                a[i] += b<<(n-j);
            }
        }
        for(int i = 1; i <= m; i++)
        {
            for(int j = 0; j < top; j++)
            {
                if(i == 1 && (num[j]|a[i])<=a[i])
                    dp[i][num[j]]++;
                else
                {
                    if((num[j]|a[i])<=a[i])
                    {
                        for(int k = 0; k < top; k++)
                        {
                            if(!(num[j]&num[k]) && (num[k]|a[i-1])<=a[i-1])
                                dp[i][num[j]] += dp[i-1][num[k]];
                        }
                    }
                }
            }
        }
        int ans = 0;
        for(int i = 0; i < top; i++)
        {
            ans += dp[m][num[i]];
        }
        cout << ans%100000000 << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值