地址:http://acm.hdu.edu.cn/showproblem.php?pid=1851
A Simple Game
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/65535 K (Java/Others)Total Submission(s): 939 Accepted Submission(s): 584
Problem Description
Agrael likes play a simple game with his friend Animal during the classes. In this Game there are n piles of stones numbered from 1 to n, the 1st pile has M
1 stones, the 2nd pile has M
2 stones, ... and the n-th pile contain M
n stones. Agrael and Animal take turns to move and in each move each of the players can take at most L
1stones from the 1st pile or take at most L
2 stones from the 2nd pile or ... or take L
n stones from the n-th pile. The player who takes the last stone wins.
After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?
The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.
After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?
The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.
Input
The first line contains the number of test cases. Each test cases begin with the number n (n ≤ 10), represent there are n piles. Then there are n lines follows, the i-th line contains two numbers M
i and L
i (20 ≥ M
i > 0, 20 ≥ L
i > 0).
Output
Your program output one line per case, if Agrael can win the game print "Yes", else print "No".
Sample Input
2 1 5 4 2 1 1 2 2
Sample Output
Yes No
思路:这题可以看为对组威佐夫博奕,用SG函数直接返回走必胜点需要拿去的石子数就行。
代码:
#include<cmath>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define LL __int64
int dfs(int m,int l)
{
if(l>=m) return m;
else return m%(l+1);
}
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
int ans=0,m,l;
while(n--)
{
scanf("%d%d",&m,&l);
ans^=dfs(m,l);
}
puts(ans?"No":"Yes");
}
return 0;
}