OSPF Guide --<转>

【FRRouting User Guide】(一)概述 FRR是一个功能齐全、高性能的免费软件IP路由套件。 FRR实现了所有的标准路由协议,如BGP、RIP、OSPF、IS-IS等(参见功能矩阵),以及它们的许多扩展。 FRR是一个主要用C语言编写的高性能套件,它可以轻松地处理完整的Internet路由表,并且适用于从廉价sbc(系统基础芯片)到商用级路由器的硬件。它被数百家公司、大学、研究实验室和政府积极用于生产。 FRR是在GPLv2下发布的,其开发是模仿Linux内核的。任何人都可以提供功能、错误修复、工具、文档更新或其他... 阅读详情
from —  http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a0080094e9e.shtml#intro

Introduction

The Open Shortest Path First (OSPF) protocol, defined in RFC 2328 , is an Interior Gateway Protocol used to distribute routing information within a single Autonomous System. This paper examines how OSPF works and how it can be used to design and build large and complicated networks.

Background Information

OSPF protocol was developed due to a need in the internet community to introduce a high functionality non-proprietary Internal Gateway Protocol (IGP) for the TCP/IP protocol family. The discussion of the creation of a common interoperable IGP for the Internet started in 1988 and did not get formalized until 1991. At that time the OSPF Working Group requested that OSPF be considered for advancement to Draft Internet Standard.

The OSPF protocol is based on link-state technology, which is a departure from the Bellman-Ford vector based algorithms used in traditional Internet routing protocols such as RIP. OSPF has introduced new concepts such as authentication of routing updates, Variable Length Subnet Masks (VLSM), route summarization, and so forth.

OSPF versus RIP

The rapid growth and expansion of today’s networks has pushed RIP to its limits. RIP has certain limitations that can cause problems in large networks:

RIP has a limit of 15 hops. A RIP network that spans more than 15 hops (15 routers) is considered unreachable.

RIP cannot handle Variable Length Subnet Masks (VLSM). Given the shortage of IP addresses and the flexibility VLSM gives in the efficient assignment of IP addresses, this is considered a major flaw.

Periodic broadcasts of the full routing table consume a large amount of bandwidth. This is a major problem with large networks especially on slow links and WAN clouds.

RIP converges slower than OSPF. In large networks convergence gets to be in the order of minutes. RIP routers go through a period of a hold-down and garbage collection and slowly time-out information that has not been received recently. This is inappropriate in large environments and could cause routing inconsistencies.

RIP has no concept of network delays and link costs. Routing decisions are based on hop counts. The path with the lowest hop count to the destination is always preferred even if the longer path has a better aggregate link bandwidth and less delays.

RIP networks are flat networks. There is no concept of areas or boundaries. With the introduction of classless routing and the intelligent use of aggregation and summarization, RIP networks seem to have fallen behind.

Some enhancements were introduced in a new version of RIP called RIP2. RIP2 addresses the issues ofVLSM, authentication, and multicast routing updates. RIP2 is not a big improvement over RIP (now called RIP 1) because it still has the limitations of hop counts and slow convergence which are essential in todays large networks.

OSPF, on the other hand, addresses most of the issues previously presented:

With OSPF, there is no limitation on the hop count.

The intelligent use of VLSM is very useful in IP address allocation.

OSPF uses IP multicast to send link-state updates. This ensures less processing on routers that are not listening to OSPF packets. Also, updates are only sent in case routing changes occur instead of periodically. This ensures a better use of bandwidth.

OSPF has better convergence than RIP. This is because routing changes are propagated instantaneously and not periodically.

OSPF allows for better load balancing.

OSPF allows for a logical definition of networks where routers can be divided into areas. This limits the explosion of link state updates over the whole network. This also provides a mechanism for aggregating routes and cutting down on the unnecessary propagation of subnet information.

OSPF allows for routing authentication by using different methods of password authentication.

OSPF allows for the transfer and tagging of external routes injected into an Autonomous System. This keeps track of external routes injected by exterior protocols such as BGP.

This of course leads to more complexity in the configuration and troubleshooting of OSPF networks. Administrators that are used to the simplicity of RIP are challenged with the amount of new information they have to learn in order to keep up with OSPF networks. Also, this introduces more overhead in memory allocation and CPU utilization. Some of the routers running RIP might have to be upgraded in order to handle the overhead caused by OSPF.

What Do We Mean by Link-States?

OSPF is a link-state protocol. We could think of a link as being an interface on the router. The state of the link is a description of that interface and of its relationship to its neighboring routers. A description of the interface would include, for example, the IP address of the interface, the mask, the type of network it is connected to, the routers connected to that network and so on. The collection of all these link-states would form a link-state database.

Shortest Path First Algorithm

OSPF uses a shorted path first algorithm in order to build and calculate the shortest path to all known destinations.The shortest path is calculated with the use of the Dijkstra algorithm. The algorithm by itself is quite complicated. This is a very high level, simplified way of looking at the various steps of the algorithm:

Upon initialization or due to any change in routing information, a router generates a link-state advertisement. This advertisement represents the collection of all link-states on that router.

All routers exchange link-states by means of flooding. Each router that receives a link-state update should store a copy in its link-state database and then propagate the update to other routers.

After the database of each router is completed, the router calculates a Shortest Path Tree to all destinations. The router uses the Dijkstra algorithm in order to calculate the shortest path tree. The destinations, the associated cost and the next hop to reach those destinations form the IP routing table.

In case no changes in the OSPF network occur, such as cost of a link or a network being added or deleted, OSPF should be very quiet. Any changes that occur are communicated through link-state packets, and the Dijkstra algorithm is recalculated in order to find the shortest path.

The algorithm places each router at the root of a tree and calculates the shortest path to each destination based on the cumulative cost required to reach that destination. Each router will have its own view of the topology even though all the routers will build a shortest path tree using the same link-state database. The following sections indicate what is involved in building a shortest path tree.

OSPF Cost

The cost (also called metric) of an interface in OSPF is an indication of the overhead required to send packets across a certain interface. The cost of an interface is inversely proportional to the bandwidth of that interface. A higher bandwidth indicates a lower cost. There is more overhead (higher cost) and time delays involved in crossing a 56k serial line than crossing a 10M ethernet line. The formula used to calculate the cost is:

cost= 10000 0000/bandwith in bps

For example, it will cost 10 EXP8/10 EXP7 = 10 to cross a 10M Ethernet line and will cost 10 EXP8/1544000 = 64 to cross a T1 line.

By default, the cost of an interface is calculated based on the bandwidth; you can force the cost of an interface with the ip ospf cost <value> interface subconfiguration mode command.

63、Open Shortest Path Protocol (OSPF) Configuration Guide This blog provides a comprehensive guide to configuring the Open Shortest Path First (OSPF) routing protocol. It covers essential commands for single-area OSPF setup, interface advertisement using wildcard masks, loopback interfaces, cost metrics modificat 阅读详情

相关推荐

深入解析OSPF协议及其在CCNA考试中的重要性

本文深入探讨了开放最短路径优先(OSPF)协议的工作原理、配置、验证和故障排除方法,并结合CCNA考试的要点进行了详细解读。文章首先介绍了OSPF的基本概念和优势,包括其作为内部网关协议(IGP)的特性和在多接入网络上处理邻接关系和链路状态通告(LSA)泛洪的机制。接着,文章通过图表和详细解释了OSPF数据包的结构,包括不同类型的OSPF数据包和它们在路由过程中的作用。文章最后通过讨论DR/BDR选举机制和OSPF算法,展示了OSPF路由器如何维护网络的稳定性和高效性。

weixin_42400643的博客 826

Frrouting快速入门——OSPF组网(一)

FRR是FRRouting的简称,是一个开源的路由交换软件套件。其作者源自老牌项目quaga的成员,也可以算是的新版本。FRR支持的协议众多,也有较为完备的北向接口。FRR的安装方式多种多样,如仅仅把它当做工具使用,使用docker运行FRR是一个不错的选择。docker方式运行frr时需要注意:较新版本FRR的docker仓库由quay.io维护,并没有在dockerhub中。

水中加点糖 6296

USRP X410 MPM版本与主机UHD版本不匹配问题记录与解决

至此大功告成!之前安装软件的坑算是填起来了,再次记录一下,希望能帮到有同样问题的小伙伴~

yanzuwu233的博客 1434

OSPF和ISIS

【1】利用quagga进行OSPF实验_郑大哲_新浪博客 【2】powerpc平台移植zebra或quagga-0.99.23 - zxiaocheng - 博客园 【3】Linux Quagga守护进程启动 【4】Quagga 简介 - Vinllen Chen - 优快云博客 【5】OSPF区域与汇总 - 百度文库 【6】OSPF配置命令 - 百度文库 【7】cisco 路由器配置 ospf命令总结 - weixin_34148340的博客 - 优快云博客 【8】iproute2;高级路由;ip_r

lra2003的博客 573

STM32F103C8T6+A4988驱动42步进电机全流程(附接线图+代码解析)

本文详细介绍了使用STM32F103C8T6单片机与A4988驱动模块控制42步进电机的完整流程。内容涵盖硬件接线图解析、电流设置、GPIO驱动代码编写以及细分控制等核心实践,旨在帮助嵌入式开发者和DIY爱好者快速实现精准运动控制,适用于3D打印机、CNC等需要精密定位的项目。

Python的专栏 792

泛微Ecology流程数据表结构解析:workflow_requestbase和workflow_currentoperator到底怎么关联查询?

本文深入解析泛微Ecology系统中workflow_requestbase和workflow_currentoperator表的结构与关联机制,提供SQL查询语句示例,帮助开发者高效查询流程数据。涵盖待办事项、已办事项、办结事项和流程监控等典型场景,并分享性能优化技巧和常见问题排查指南。

weixin_33738555的博客 807

Cisco OSPF 数据包类型指南

…

u013669912的博客 1368

注册“Oracle Provider for OLE DB”和创建链接服务器

注册“Oracle Provider for OLE DB”和创建链接服务器 在sql server 数据库上创建链接服务器,连接oracle数据库,访问接口需要设置为:“Oracle Provider for OLE DB”。 如果电脑上没有这个驱动,安装一个完整的Oracle11gR2程序是一个有效的方法,但这个64位版本的安装包有2个多G, 相当庞大,如果仅仅...

weixin_30760895的博客 2384

IP Routing: OSPF Configuration Guide, Cisco IOS Release 15SY

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_ospf/configuration/15-sy/iro-15-sy-book.html

blakegao的专栏 744

《实战指南 | MES业务顾问蓝图设计方案:避免90%项目踩坑,从战略到落地的全攻略》

《MES业务顾问蓝图设计方案》干货分享:制造业高管常遇MES系统沦为"摆设"的困境,根源在于蓝图设计阶段未抓准业务痛点。本文系统梳理了6大关键点:1)战略定位上承ERP下接设备;2)通过现场蹲点挖掘真实需求;3)构建可扩展技术架构;4)建立数据闭环管理;5)组织保障分步实施;6)持续量化KPI优化。方案强调从业务价值出发,避免"纸上谈兵",通过数据驱动实现"计划-执行-反馈"闭环,最终让MES成为企业数字化的核心资产。

「东哥说MES」 专注于MES制造执行系统,为你拆解核心架构、功能模块及与ERP/PLC的集成逻辑。提供从入门到精通的系列干货、精选行业报告与实用工具,构建你的数字化知识体系,关注我,用实战经验照亮你的数字化之路。 1334

使用plot函数可视化F分布累积分布函数数据(R语言)

在上面的代码中,我们使用了seq()函数来生成从0到5之间,以0.1为步长的一组F值。然后,我们指定了分子自由度为3,分母自由度为8,并使用pf()函数计算了对应的F分布CDF值。在本文中,我们将介绍如何使用R语言的plot函数来可视化F分布的累积分布函数(CDF)数据。通过使用plot函数,我们可以直观地了解F分布的累积分布函数,并对F值和对应的累积概率之间的关系有更深入的认识。运行上述代码后,我们将获得一个由F值和对应的累积概率构成的图形,其中x轴表示F值,y轴表示累积概率。

LogicGuruX的博客 502

[原创]让我们一起CCNA吧系列文章六:EIGRP and OSPF

本系列文章主要针对CCNA 640-801的学习者,学习课程为SYBEX的《Cisco Certified Network Associate Study Guide Fourth Edition》本章思科的考试内容包括:设计与规划·基于用户需求选择一个合适的路由协议·用思科的技术设计一个简单的互连网络执行与操作·基于用户要求配置路由协议增强型内部网关协议(Enhanced Interior Ga

落叶树的BLOG 3867

Oracle EBS(R12+)通过Multi-Org 多组织架构、Multi-Ledger 多账簿、SLA 子分类账会计、多币种引擎、多会计政策并行五大核心能力,为跨国企业提供一体化、自动化、合规的

Oracle EBS(R12+)提供全球会计核算解决方案,通过Multi-Org多组织架构实现跨国集团数据隔离与共享,支持四层组织结构(业务组→法律实体→经营单位→库存组织)。Multi-Ledger多账簿功能允许一笔业务多准则自动核算,包含主账簿、辅助账簿和报告币种。系统内置多币种处理引擎,覆盖全流程货币业务,支持自动重估、再计量和折算。通过SLA子分类账会计实现多会计政策并行处理,满足不同国家会计准则和税制要求。该方案可同时支持本地法定、集团合并及管理分析需求,实现全球财务数据集中管理,提升合规性和运营

金牌架构师 553

CCIE Routing and Switching Exam Certification Guide

版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章原始出版、作者信息和本声明。否则将追究法律责任。http://blog.youkuaiyun.com/topmvp - topmvpThe official study guide helps you master all the topics on the CCIE Routing and Switching written exam, incl

TopMVP 668

【软考中级网络工程师】知识点之 IP QoS 技术

本文围绕软考中级网络工程师必备的 IP QoS 技术展开,系统阐述其核心知识。首先解析 IP QoS 的定义、重要性及应用场景,揭示其在视频会议、在线游戏等场景的关键作用;接着深入讲解技术原理,包括流量分类与标记、整形与限速、拥塞管理及 RSVP 协议;随后对比尽力而为、IntServ、DiffServ 三种服务模型的特点;还介绍了配置实践与案例分析,探讨其与 SDN、5G 等技术的融合趋势。旨在帮助读者全面掌握 IP QoS 技术要点,为网络规划与优化提供理论与实践指导。

邓邓子的博客 1086

pscad IEEE标准系统搭建说明

pscad IEEE标准系统搭建说明,包含典型的IEEE 9节点、14节点、30节点、39节点和118节点系统。内含标准测试系统的原始数据和潮流结果。

OSPF学习经验心得

提起 OSPF ,很多人都说很难。但也常常听到这样的声音:我 RFC2328 不到一个周就看完了。的确不错,一篇 RFC2328 区区 244 页,在众多英语流利、根底深厚的好手面前,一天读完也不恐为过,但是要做到整个协议的融会贯通在这么短的时间内是远远做不到的。有人形容 OSPF 是网络协议中的“葵花宝典”,在一定的方面说的确不为过。 不管怎么样, OSPF 算法之周密、...

weixin_33912445的博客 438

VC中sqlite的使用

在VC中对sqlite的使用,实现数据库大批数据的快速插入,读取数据库中的数据在ListCtrl中显示

OSPF – P2P 链路中 Router LSA 的双重作用(Cisco)

…

u013669912的博客 916

lwip-2.0.3

lwip是瑞典计算机科学院(SICS)的Adam Dunkels 开发的一个小型开源的TCP/IP协议栈。实现的重点是在保持TCP协议主要功能的基础上减少对RAM 的占用。

霍尼韦尔SoftMaster使用说明

霍尼韦尔SoftMaster使用说明

CCNP BSCI Portable Command Guide

版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章原始出版、作者信息和本声明。否则将追究法律责任。http://blog.youkuaiyun.com/topmvp - topmvpThe guide summarizes all CCNP certification-level Cisco IOS® Software commands, keywords, command arguments,

TopMVP 395

FRRouting User Guide

原文:http://docs.frrouting.org/en/latest/ Introduction Overview How to get FRR About FRR Mailing Lists Bug Reports Installation From Packages From Snapcraft From Source Basic Setup Crash logs Daemons Configuration File Services Sy

weixin_39094034的博客 915

ospf与其他路由协议重分发的默认表现

ospf与不同路由协议的重分发时,默认有不同的表现:对于bgp,不指定match类型只重分发internal,除非指定external关键字。。对于rip,不指定则是两者都有。。 http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/5242-bgp-ospf-redis.html#redistrib

blakegao的专栏 1400

CCNP BSCI Official Exam Certification Guide

版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章原始出版、作者信息和本声明。否则将追究法律责任。http://blog.youkuaiyun.com/topmvp - topmvpThe official study guide helps you master all the topics on the CCNP BSCI exam, including*Essential routi

TopMVP 803

CCNA ICND2 Official Exam Certification Guide

版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章原始出版、作者信息和本声明。否则将追究法律责任。http://blog.youkuaiyun.com/topmvp - topmvpThe official study guide helps you master all the topics on the CCNA ICND2 exam, including*Virtual LANs a

TopMVP 408

OSPF(开放最短路径优先)

OSPF (Open Shortest Path First) is a routing protocol used in IP networks. It is based on the Shortest Path First (SPF) algorithm and falls into the category of interior gateway protocols (IGPs). OSPF operates within a single autonomous system (AS) and is

qq_36361541的博客 628

(OK)(www.nrl.navy.mil) OSPF MANET Designated Routers (OSPF-MDR) Implementation

Overview The OSPF-MDR implementation for quagga OSPFv3 is an implementation of RFC 5614 (OSPF MDR), RFC 5243 (OSPF Database Exchange Optimization), and RFC 5838 (OSPFv3 Address Families) for ef

张同光 (Tongguang Zhang):Hello everyone ! 1256
上一篇: Shell脚本中cd命令使用
下一篇: pushd,popd,dirs–Bash实现
firefoxbug
博客等级 码龄16年 259粉丝 165原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

个

红包个数最小为10个

元

红包金额最低5元

当前余额3.43元 前往充值 >
需支付:10.00元
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值