7-6 字符串排序 (20 分)

本题要求编写程序,读入5个字符串,按由小到大的顺序输出。

输入格式:

输入为由空格分隔的5个非空字符串,每个字符串不包括空格、制表符、换行符等空白字符,长度小于80。

输出格式:

按照以下格式输出排序后的结果:

After sorted:
每行一个字符串

输入样例:

red yellow blue black white

结尾无空行

输出样例:

After sorted:
black
blue
red
white
yellow

结尾无空行

我的代码:

#include <stdio.h>
#include <string.h>

int main() {
	int i, j, n = 0;
	char str[81][81];
	char ch;
	scanf("%s", str[n++]);
	ch = getchar();
	while (ch != '\n') {
		scanf("%s", str[n++]);
		ch = getchar();
	}
    //ch抵消空格和换行
	getchar();
	for (i = 0; i < n - 1; i++) {
		for (j = 0; j < n - i - 1; j++) {
			if (strcmp(str[j], str[j + 1]) > 0) {
				char temp[81];
				strcpy(temp, str[j]);
				strcpy(str[j], str[j + 1]);
				strcpy(str[j + 1], temp);
			}
		}
	}
	printf("After sorted:\n");
	for (i = 0; i < n; i++)
		printf("%s\n", str[i]);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值