Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 26336 Accepted Submission(s): 9880
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
Sample Output
105 10296
Source
Recommend
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int rem(int a,int b)
{
int c=a%b;
//printf("a %d a\n",a);
//printf("b %d b\n",b);
//printf("c %d c\n",c);
if(c==0)
return b;
else
{
a=b;
b=c;
rem(a,b);
}
}
int mul(int a,int b)
{
//cout<<"rem"<<rem(a,b)<<"rem"<<endl;
//printf("%d %d\n",a,b);
return a/(rem(a,b))*b;//先除后乘,防止溢出,不过为什么改成__int64之后传错值了呢
}
int main()
{
int s[100];
int i,j,n,m,t;
while(scanf("%d",&n)!=EOF)
{
while(n--)
{
scanf("%d",&m);
for(j=0;j<m;j++)
scanf("%d",&s[j]);
t=s[0];
/*for(i=0;i<m;i++)
printf("m %d m\n",s[i]);*/
for(i=1;i<m;i++)
{
//printf("%d gg %d\n",t,s[i]);
t=mul(t,s[i]);
}
cout<<t<<endl;
}
}
return 0;
}