POJ 2524 并查集

Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 17935 Accepted: 8748

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.
You know that there are n students in your university (0 < n < = 50000). It is infeasible for you to ask every student their  religious beliefs. Furthermore, many students are not comfortable  expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <=  n(n-1)/2) pairs of students and ask them whether they  believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person  believes in, but you can get an idea of the upper bound of how many  different religions can be possibly represented on campus. You may  assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line  specifying the integers n and m. The next m lines each consists of two  integers i and j, specifying that students i and j believe in the same  religion. The students are numbered 1 to n. The end of input is  specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with  1) followed by the maximum number of different religions that the  students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7
最简单的并查集 没什么可以说的 直接看代码吧
#include <stdio.h>
#define MAXNUM 50001
//记录学生I所在宗教集合的父结点
int parent[MAXNUM];
//初始化
void init()
{
    for(int i = 1; i < MAXNUM; i++)
    parent[i] = i;
}

//找到a的父亲,即当前宗教集合的父亲
int find(int a)
{
    if(parent[a]==a)
    return a;
    //int tem = parent[a];
    parent[a] = find(parent[a]);//更新所有的结点的父亲:更新域并压缩路径
    return parent[a];
}
int main()
{
    //N个学生,M组
    int N,M;
    //学生I,学生J
    int I,J;
    //学生I、J所在宗教集合的根
    int ri,rj;

    int m;
    //case 计数
     m = 1;
    while(1)
    {
        init();
        scanf("%d%d",&N,&M);
        if(N==0&&M==0)break;

        while(M--)
        {
            scanf("%d%d",&I,&J);
            //if(I>N||J>N)continue;
            //找到宗教的根结点
            ri = find(I);
            rj = find(J);
            //若两个学生不在一个集合,合并,同时宗教数目较少一种
            if(ri!=rj)
            {
                //合并集合
                parent[ri] = rj;
                //宗教的种类减少一种
                N--;
            }
        }
        printf("Case %d: %d\n",m++,N);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/LOB104-zhanglei/articles/3187459.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值