hdu 3333 Turing Tree(树状数组 + 离线查询)

Turing Tree

Description

After inventing Turing Tree, 3xian always felt boring when solving problems about intervals, because Turing Tree could easily have the solution. As well, wily 3xian made lots of new problems about intervals. So, today, this sick thing happens again... 

Now given a sequence of N numbers A1, A2, ..., AN and a number of Queries(i, j) (1≤i≤j≤N). For each Query(i, j), you are to caculate the sum of distinct values in the subsequence Ai, Ai+1, ..., Aj.

Input

The first line is an integer T (1 ≤ T ≤ 10), indecating the number of testcases below. 
For each case, the input format will be like this: 
* Line 1: N (1 ≤ N ≤ 30,000). 
* Line 2: N integers A1, A2, ..., AN (0 ≤ Ai ≤ 1,000,000,000). 
* Line 3: Q (1 ≤ Q ≤ 100,000), the number of Queries. 
* Next Q lines: each line contains 2 integers i, j representing a Query (1 ≤ i ≤ j ≤ N).

Output

For each Query, print the sum of distinct values of the specified subsequence in one line.

Sample Input

2
3
1 1 4
2
1 2
2 3
5
1 1 2 1 3
3
1 5
2 4
3 5

Sample Output

1
5
6
3
6

为了写一道cf的题专门来做了这题,题意是求区间内不同的数之和,方法是离线查询:将要询问的区间保存下来,按照区间右端点的大小排序,这样的话在查询后一个区间时,前面已经处理完了(将已出现过的数字置为0,只保留最后一个),用树状数组简单的区间求和。

#include <bits/stdc++.h>
using namespace std;
#define ll long long
const int maxn = 1e5 + 10;
ll a[maxn];
ll c[maxn];
int n;

struct node {
    int l, r, id;
    ll ans = 0;
}p[maxn];

inline ll lowbit(ll x) {
    return x & (-x);
}

ll sum(int x) {
    ll ret = 0;
    while(x > 0) {
        ret += c[x]; x -= lowbit(x);
    }
    return ret;
}

void add(int x, ll d) {
    while(x <= n) {
        c[x] += d; x += lowbit(x);
    }
}

bool cmp1(node a, node b) {
    return a.r < b.r;
}

bool cmp2(node a, node b) {
    return a.id < b.id;
}

int main() {
    int t;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) scanf("%I64d", &a[i]);
        int m;
        scanf("%d", &m);
        for(int i = 1; i <= m; i++) {
            scanf("%d %d", &p[i].l, &p[i].r);
            p[i].id = i;
        }
        sort(p + 1, p + 1 + m, cmp1);
        memset(c, 0, sizeof(c));
        map<int, int> mp;
        int pos = 1;
        for(int i = 1; i <= n; i++) {
            if(mp[a[i]]) {
                add(mp[a[i]], -a[i]);
                a[mp[a[i]]] = 0;
            }
            mp[a[i]] = i;
            add(i, a[i]);
            for( ; pos <= m && p[pos].r == i; pos++) {
                p[pos].ans = sum(p[pos].r) - sum(p[pos].l - 1);
            }
        }
        sort(p + 1, p + 1 + m, cmp2);
        for(int i = 1; i <= m; i++) {
            printf("%I64d\n", p[i].ans);
        }
    }
}

 

转载于:https://www.cnblogs.com/lonewanderer/p/5767333.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值