hdu 5791 Two

Two

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 21    Accepted Submission(s): 10


Problem Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.
 

 

Input
The input contains multiple test cases.

For each test case, the first line cantains two integers  N,M(1N,M1000). The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.
 

 

Output
For each test case, output the answer mod 1000000007.
 

 

Sample Input
3 2
1 2 3
2 1
3 2
1 2 3
1 2
 
 
Sample Output
2
3

 类似最长公共子序列的dp。

#include <bits/stdc++.h>
using namespace std;
#define ll long long
const int maxn = 1e5 + 10;
ll a[maxn], b[maxn];
ll sum[maxn];
const ll mod = 1000000007;
ll dp[1010][1010];
int main() {
    int n, m;
    while(~scanf("%d %d", &n, &m)) {
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++) scanf("%I64d", &a[i]);
        for(int i = 1; i <= m; i++) scanf("%I64d", &b[i]);
        for(int i = 1; i <= n; i++) {
            for(int j = 1; j <= m; j++) {
                dp[i][j] = (((dp[i - 1][j] + dp[i][j - 1]) % mod - dp[i - 1][j - 1] + mod) + (a[i] == b[j] ? dp[i - 1][j - 1] + 1 : 0)) % mod;
            }
        }
        printf("%I64d\n", dp[n][m] % mod);
    }
}

 

转载于:https://www.cnblogs.com/lonewanderer/p/5730065.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值