Bellovin||HDU5748

link:http://acm.hdu.edu.cn/showproblem.php?pid=5748
Problem Description

Peter has a sequence a1,a2,...,an and he define a function on the sequence -- F(a1,a2,...,an)=(f1,f2,...,fn), where fi is the length of the longest increasing subsequence ending with ai.

Peter would like to find another sequence b1,b2,...,bn in such a manner that F(a1,a2,...,an) equals to F(b1,b2,...,bn). Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,...,an is lexicographically smaller than sequence b1,b2,...,bn, if there is such number i from 1 to n, that ak=bk for 1≤k<i and ai<bi.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains an integer n (1≤n≤100000) -- the length of the sequence. The second line contains n integers a1,a2,...,an (1≤ai≤109).

Output

For each test case, output n integers b1,b2,...,bn (1≤bi≤109) denoting the lexicographically smallest sequence.

Sample Input

3
1
10
5
5 4 3 2 1
3
1 3 5

Sample Output

1
1 1 1 1 1
1 2 3

题解:LIS,o(nlogn)算法,可以参考我的这个http://blog.youkuaiyun.com/csdn_muxin/article/details/76998459

中文题面:http://bestcoder.hdu.edu.cn/contests/contest_chineseproblem.php?cid=718&pid=1002

这道题要注意!!!!

s[i]=upper_bound(dp,dp+n,a[i])-dp;
            //要么这样用,要么用lower加a[i]然后数值加一,不能用lower加INF,不然WA 

AC代码

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
const int MAX=100010;
int INF=1000000100;
int a[MAX],dp[MAX],s[MAX];
int main()
{
    int t,n,i; 
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
//          dp[i]=INF;
//          s[MAX]=0;
        }
        fill(dp,dp+n,INF);
        for(i=0;i<n;i++)
        {
            *lower_bound(dp,dp+n,a[i])=a[i];
            s[i]=upper_bound(dp,dp+n,a[i])-dp;
            //要么这样用,要么用lower加a[i]然后数值加一,不能用lower加INF,不然WA 
        }
        for(i=0;i<n;i++)
        {
            printf("%d%c",s[i],i==(n-1)?'\n':' ');
        }
    }
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三更鬼

谢谢老板!

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值