1105 Spiral Matrix (25 point(s))

1105 Spiral Matrix (25 point(s))

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−nis the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

模拟题。元素的规律填充。

思路:

1. 先确定行数、列数;

2. 考虑填充过程。对于给定的范围(M*N),用i和j表示坐标,用dirIndex方向的控制指标,从(0,0)开始,依次向右、下、左、上移动。对于每一步确定下一个元素的坐标,如果按照当前方向,新的坐标会超出给定范围或者该元素已经有了元素,则变换方向,否则保持当前方向。直到所有元素填充完。

3. 按照格式输出。 

#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e4+7;
int n[MAX];
bool cmp(int a,int b){return a>b;}
int main(void){
	int N;cin>>N;
	for(int i=0;i<N;i++) cin>>n[i];
	sort(n,n+N,cmp);//排序 
	int col = sqrt(N);//确定这个矩形的高和宽 
	do{
		if(N%col==0) break;
	}while(col--);
	int row = N/col;
	int a[row][col];
	memset(a,0,sizeof(a));
	int i=0,j=-1;//初始位置 
	int dirIndex = 0;
	int dir[4][2]={0,1, 1,0, 0,-1, -1,0};
	for(int k=0;k<N;k++){
		int ii = i+dir[dirIndex%4][0];
		int jj = j+dir[dirIndex%4][1];
		if(ii<0||ii>=row||jj<0||jj>=col||a[ii][jj]!=0){
		//如果继续维持当前方向发生超出范围 
			dirIndex++;//变更方向 
		} 
		i = i+dir[dirIndex%4][0];
		j = j+dir[dirIndex%4][1];
		a[i][j]=n[k];
	}
	for(int i=0;i<row;i++){
		for(int j=0;j<col;j++){
			if(j==0) cout<<a[i][j];
			else cout<<" "<<a[i][j];
		}
		cout<<endl;
	}
	return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值