UVA 639 - Don't Get Rooked(深搜)

Don't Get Rooked 

In chess, the rook is a piece that can move any number of squares vertically or horizontally. In this problem we will consider small chess boards (at most 4$\times$4) that can also contain walls through which rooks cannot move. The goal is to place as many rooks on a board as possible so that no two can capture each other. A configuration of rooks is legal provided that no two rooks are on the same horizontal row or vertical column unless there is at least one wall separating them.


The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of rooks in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a board, calculates the maximum number of rooks that can be placed on the board in a legal configuration.

Input 

The input file contains one or more board descriptions, followed by a line containing the number 0 that signals the end of the file. Each board description begins with a line containing a positive integer  n  that is the size of the board;  n  will be at most 4. The next  n  lines each describe one row of the board, with a ` . ' indicating an open space and an uppercase ` X ' indicating a wall. There are no spaces in the input file.

Output 

For each test case, output one line containing the maximum number of rooks that can be placed on the board in a legal configuration.

Sample Input 

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output 

5
1
5
2
4

==============================

从每一个可以放置的位置开始深搜


#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

int n,maxans;
char map[10][10],vis[10][10];

bool check(int x, int y)
{
    if(vis[x][y]==-1||vis[x][y]==1) return 0;
    for(int i=x+1;i<=n&&map[i][y]!='X';i++)
        if(vis[i][y]==-1)
            return 0;
    for(int i=x-1;i>=1&&map[i][y]!='X';i--)
        if(vis[i][y]==-1)
            return 0;
    for(int i=y+1;i<=n&&map[x][i]!='X';i++)
        if(vis[x][i]==-1)
            return 0;
    for (int i=y-1;i>=1&&map[x][i]!='X';i--)
        if(vis[x][i]==-1)
            return 0;
    return 1;
}

void dfs(int ans)
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(check(i,j))
            {
                vis[i][j]=-1;
                dfs(ans+1);
                vis[i][j]=0;
            }
        }
    }
    if(maxans<ans)
    {
        maxans=ans;
    }
    return;
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        maxans=-1;
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            scanf("%s",map[i]+1);
            for(int j=1;j<=n;j++)
            {
                if(map[i][j]=='X')
                    vis[i][j]=1;
            }
        }
        dfs(0);
        printf("%d\n",maxans);
    }
    return 0;
}


### GIB-UVA ERP-BCI HDF5 文件格式及其处理方法 HDF5 是一种用于存储大量科学数据的文件格式,广泛应用于神经科学研究领域。对于 GIB-UVA ERP-BCI 数据集中的 HDF5 文件,通常包含了脑电图(EEG)信号以及其他元数据信息。以下是关于该类文件的一些重要细节以及如何对其进行处理的方法。 #### 1. HDF5 文件结构概述 HDF5 文件是一种分层的数据存储格式,类似于文件系统的目录树结构。它支持多种数据类型,包括数组、表格和字符串等。在 GIB-UVA ERP-BCI 的上下文中,这些文件可能包含以下内容: - **实验记录**:如时间戳、采样率和其他实验参数。 - **原始 EEG 数据**:多通道的时间序列数据。 - **事件标记**:表示刺激呈现或其他行为事件的时间点。 这种层次化的结构使得研究人员可以轻松访问特定部分的数据而无需加载整个文件[^3]。 #### 2. 处理 HDF5 文件所需的工具 为了读取和操作 HDF5 文件,可以使用 Python 中的 `h5py` 或 MATLAB 提供的相关库。下面是一个简单的例子展示如何利用 `h5py` 打开并探索一个 HDF5 文件的内容: ```python import h5py def explore_hdf5(file_path): with h5py.File(file_path, 'r') as f: print("Keys:", list(f.keys())) # 列出顶层组名 for key in f.keys(): item = f[key] if isinstance(item, h5py.Dataset): print(f"{key} is a dataset with shape {item.shape}") elif isinstance(item, h5py.Group): print(f"{key} is a group containing:") for sub_key in item.keys(): print(f" - {sub_key}") explore_hdf5('example.h5') ``` 上述脚本会打印出给定 HDF5 文件的所有顶级键,并区分它们是数据集还是子组[^4]。 #### 3. 内存管理注意事项 如果尝试运行某些大型模型(例如 DeepSeek-R1),可能会遇到内存不足的情况,正如引用中提到的例子所示[^2]。在这种情况下,建议采取以下措施来优化资源分配: - 使用更高效的算法减少计算需求; - 增加物理 RAM 或启用虚拟内存扩展; - 对于 GPU 加速环境,考虑调整批次大小或切换到较低精度浮点数运算模式(FP16 vs FP32)。 此外,在处理大尺寸的 HDF5 文件时也需要注意类似的性能瓶颈问题——可以通过逐块加载而非一次性全部载入的方式来缓解这一挑战[^5]。 #### 4. 特殊情况下的预处理技术 针对 BCI 应用场景下采集得到的高维时空域特征矩阵,往往还需要执行一系列标准化流程,比如去噪滤波器应用、基线校正以及重参考变换等等。具体实现取决于实际研究目标和个人偏好设置等因素影响。 --- ###
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值