HDU-1029 Ignatius and the Princess IV

面对feng5166的挑战,Ignatius必须从给定的奇数长度数列中找到那个至少出现(n+1)/2次的特殊整数,否则公主将面临危险。本文介绍了一种简单直接的方法来解决这个问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Ignatius and the Princess IV

 

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says. 

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says. 

"But what is the characteristic of the special integer?" Ignatius asks. 

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says. 

Can you find the special integer for Ignatius? 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file. 

Output

For each test case, you have to output only one line which contains the special number you have found. 

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output

3
5
1

题目大意:给一个奇数n,长度为n的数列,找出其中出现次数不少于(n+1)/2的数字

思路:暴力

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
using namespace std;
map<int,int>mp;
int vis[1000005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int x,tot=1;
        mp.clear();
        memset(vis,0,sizeof(vis));
        int maxx=0,k;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            if(!mp[x]) mp[x]=tot++;
            vis[mp[x]]++;
            if(vis[mp[x]]>maxx)
                maxx=vis[mp[x]],k=x;
        }
        printf("%d\n",k);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值