Dungeon Master

本文介绍了一款基于三维迷宫的游戏,玩家需要找到最快的出路。通过使用深度优先搜索算法,文章提供了解决方案并分享了实现过程中的注意事项。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

                                  Dungeon Master

 

 

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

这道题就是一道简单的深搜,就是把二维变成了三维,其他的都和原来一样,要注意的是三维数组不要开太大。
还有就是我当时做这道题的时候有点脑抽了,坐标没对齐,x,y,z轴弄反了,半天没找出来错在哪,最后无意间发现的时候也是对自己很无语了,所以这里也要注意一下吧
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
char map[50][50][50];
int l,r,c,flag,go[6][3]= {1,0,0,-1,0,0,0,1,0,0,-1,0,0,0,1,0,0,-1};
int vis[50][50][50];
struct dt
{
    int x,y,z,s;
} now,next;
void bfs(int z,int x,int y)
{
    queue<dt>w;
    now.x=x,now.y=y,now.z=z,now.s=0;
    w.push(now);
    vis[z][x][y]=1;
    while(!w.empty())
    {
        now=w.front();
        w.pop();
        if(map[now.z][now.x][now.y]=='E')
        {
            flag=1;
            printf("Escaped in %d minute(s).\n",now.s);
            return ;
        }
        for(int i=0; i<6; i++)
        {
            int xx=now.x+go[i][1],yy=now.y+go[i][2],zz=now.z+go[i][0];
            if(xx>=0&&yy>=0&&zz>=0&&xx<r&&yy<c&&zz<l&&map[zz][xx][yy]!='#'&&vis[zz][xx][yy]==0)
            {
                next.x=xx,next.y=yy,next.z=zz,next.s=now.s+1;
                vis[zz][xx][yy]=1;
                w.push(next);
            }
        }
    }
    return ;
}
int main()
{
    while(~scanf("%d%d%d",&l,&r,&c)&&l&&r&&c)
    {
        int minn=0;
        flag=0;
        memset(vis,0,sizeof(vis));
        for(int i=0; i<l; i++)
        {
            for(int j=0; j<r; j++)
                scanf("%s",map[i][j]);
        }
        for(int i=0; i<l; i++)
            for(int j=0; j<r; j++)
                for(int k=0; k<c; k++)
                    if(map[i][j][k]=='S')
                    {
                        bfs(i,j,k);
                        break;
                    }
        if(!flag) printf("Trapped!\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值