记做题时犯的错
题目地址:https://pintia.cn/problem-sets/994805342720868352/problems/994805487143337984
题目描述
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai as . Here, as usual, 0≤ai<b for all i and ak is non-zero. Then N is palindromic if and only if
for all i. Zero is written 0 in any base and is also palindromic by definition.
Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
输入格式
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10^9 is the decimal number and 2≤b≤10^9 is the base. The numbers are separated by a space.
.
输出格式
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form “ak ak−1… a0”. Notice that there must be no extra space at the end of output.
输入样例1
27 2
输出样例1
Yes
1 1 0 1 1
输入样例2
121 5
输出样例2
No
4 4 1
解题思路
题意:
给出两个整数n,b,问十进制整数n在b进制下是否是回文数,若是,则输出Yes;否则,输出No。在之后输出n在b进制下的表示。
做法:
- 将整数n转换为b进制,进制转换的方法如下
do{
z[count ++] = N % b;
N = N / b;
}while(N != 0);
- 判断b进制下的n是否为回文数,比较位置i与对称位置num-1-i的数是否相同,有一对相同则不是回文数。
出错点
代码中使用的flag来标记是否为回文数,刚开始使用的判断语句是
if(flag == 1)
printf("NO\n");
else
printf("Yes\n");
然后提交的代码显示部分正确,测试点1,3,6都不能通过。把判断语句写成函数显示的也是该结果。后面将判断的顺序改变之后,
if(flag == 0)
printf("Yes\n");
else
printf("No\n");
提交的答案正确。在多次提交的过程中,不管是写成判断函数还是直接判断,顺序都不能变,不然提交之后就会出现错误。
代码
#include <iostream>
#include <string.h>
#define MaxSize 100
using namespace std;
int main() {
int N,b,count = 0;
int z[50];
int flag = 0;
scanf("%d %d",&N,&b);
do
{
z[count ++] = N % b;
N = N / b;
}while(N != 0);
for(int i = 0;i <= count / 2;i ++)
{
if(z[i] != z[count - i - 1])
{
flag = 1;
break;
}
}
if(flag == 0)
printf("Yes\n");
else
printf("No\n");
for(int i = count - 1;i >= 0;i --)
{
printf("%d",z[i]);
if(i != 0)
printf(" ");
}
return 0;
}