1146 Topological Order
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is guaranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
题意为判断给定的数列是否为给定有向图的拓扑排序
根据拓扑排序的规则,拓扑序列中点n的前面必须出现图中射向点n的点
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <vector>
using namespace std;
#define SUM 1001
struct Point {//我不爱用vector数组
vector<int> in_p;//射向该点的点
};
int n, m, k;
Point points[SUM];
vector<int> result;
int main() {
cin >> n >> m;
for (int i = 1; i <= m; i++) {
int u, v;
cin >> u >> v;
points[v].in_p.push_back(u);
}
cin >> k;
for (int i = 0; i < k; i++) {
int book[SUM] = { 0 };//点是否出现过
bool flag = false;
for (int j = 1; j <= n; j++) {
int p;
cin >> p;
book[p] = 1;
for (int a : points[p].in_p) {
if (book[a] == 0) {
flag = true;
break;
}
}
}
if (flag) {
result.push_back(i);
}
}
int len = result.size();
for (int i = 1; i <= len; i++) {
cout << result[i - 1];
if (i != len) {
cout << " ";
}
}
cout << endl;
return 0;
}