Largest Rectangle in a Histogram
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 20545 Accepted Submission(s): 6258
Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 34 1000 1000 1000 10000
Sample Output
84000
Source
#include<stdio.h>
#include<iostream>
using namespace std;
long long h[100005];
int leftt[100005],rightt[100005];//原来自定义的left变量与库中重名,所以改用leftt
int main()
{
int i,j,k,n;
while(scanf("%d",&n),n)
{
for(i=1;i<=n;i++)
{
scanf("%I64d",&h[i]);
leftt[i]=i;
rightt[i]=i;
}
h[0]=h[n+1]=-1;
for(i=1;i<=n;++i)//从左往右 求出连续比它高的最左边的下标,
while(h[leftt[i]-1]>=h[i])//当此点的高度小于等于它左边那点的高度
leftt[i]=leftt[leftt[i]-1]; //那它左端点为左边邻居的左端点
for(i=n;i>=1;--i)//从右往左 求出连续比它高的最右边的下标
while(h[rightt[i]+1]>=h[i])
rightt[i]=rightt[rightt[i]+1];
for(i=1;i<=n;++i)
printf("%d ",leftt[i]);
printf("\n");
for(i=1;i<=n;++i)
printf("%d ",rightt[i]);
printf("\n");
long long ans=0,temp;
for(i=1;i<=n;i++)//寻找最大值
{
temp=h[i]*(rightt[i]-leftt[i]+1);
ans=max(temp,ans);
}
printf("%I64d\n",ans);
}
return 0;
}