Farm Irrigation
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 10953 Accepted Submission(s): 4799
Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.
Figure 1
Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map
ADC
FJK
IHE
then the water pipes are distributed like
Figure 2
Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.
Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?
Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map
ADC
FJK
IHE
then the water pipes are distributed like

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.
Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?
Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
Output
For each test case, output in one line the least number of wellsprings needed.
Sample Input
2 2 DK HF 3 3 ADC FJK IHE -1 -1
Sample Output
2 3
//油田问题加强版,判断能分出几块 很有趣
#include<stdio.h>
#include<string.h>
char map[55][55];
int vis[55][55];
int mod[11][4]={ {1,0,0,1},{1,1,0,0},{0,0,1,1},{0,1,1,0},
{1,0,1,0},{0,1,0,1},{1,1,0,1},{1,0,1,1},
{0,1,1,1},{1,1,1,0},{1,1,1,1}}; //11个模块方向是否可走 上0,右1,下2,左3 顺时针
int m,n;
int dir[4][2]={{0,1},{0,-1},{-1,0},{1,0}};//右,左,上,下 对于这个题来说方向的二维数组具体的值非常重要。
//需要与坐标系原点是左上角,二维数组的第一个元素是行数的,第二个元素是列数。
//如果赋值是错误的,那下面两个方块接口是否连在一起的判断是没有意义的。
//其他题则无所谓,只要是4个方向就好了。
int judge(int dir,char one, char two){
int oldclass = one - 'A'; //计算出目前属于哪种类型的土地
int nowclass = two - 'A';
//printf("%d: %c %c\n",dir,one,two);
if(dir==0&&mod[oldclass][1]&&mod[nowclass][3])
return 1;
else if(dir==1&&mod[oldclass][3]&&mod[nowclass][1])
return 1;
else if(dir==2&&mod[oldclass][0]&&mod[nowclass][2])
return 1;
else if(dir==3&&mod[oldclass][2]&&mod[nowclass][0])
return 1;
return 0;
}
void dfs(int x,int y)
{
char old=map[x][y];
vis[x][y]=1;
for(int i=0;i<4;i++)
{
int a=x+dir[i][0];
int b=y+dir[i][1];
if(a>=0&&a<n&&b>=0&&b<m&&!vis[a][b])
{
char now=map[a][b];
if(judge(i,old,now))
dfs(a,b);
else
continue;
}
}
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF&&n!=-1&&m!=-1)
{
for(int i=0;i<n;i++)
{
getchar();
scanf("%s",map[i]);
}
memset(vis,0,sizeof(vis));
int ans=0;
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
{
if(!vis[i][j])
{
ans++;
dfs(i,j);
}
}
printf("%d\n",ans);
getchar();//吸收多组测试数据直接的空行
}
return 0;
}