Spy's Work
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1196 Accepted Submission(s): 364
Problem Description
I'm a manager of a large trading company, called ACM, and responsible for the market research. Recently, another trading company, called ICPC, is set up suddenly. It's obvious that we are the competitor to each other now!
To get some information about ICPC, I have learned a lot about it. ICPC has N staffs now (numbered from 1 to N, and boss is 1), and anybody has at most one superior. To increase the efficiency of the whole company, the company contains N departments and the ith department is led by the ith staff. All subordinates of the ith staff are also belong to the ith department.
Last week, we hire a spy stealing into ICPC to get some information about salaries of staffs. Not getting the detail about each one, the spy only gets some information about some departments: the sum of the salaries of staff s working for the ith department is less than (more than or equal to) w. Although the some inaccurate information, we can also get some important intelligence from it.
Now I only concerned about whether the spy is telling a lie to us, that is to say, there will be some conflicts in the information. So I invite you, the talented programmer, to help me check the correction of the information. Pay attention, my dear friend, each staff of ICPC will always get a salary even if it just 1 dollar!
To get some information about ICPC, I have learned a lot about it. ICPC has N staffs now (numbered from 1 to N, and boss is 1), and anybody has at most one superior. To increase the efficiency of the whole company, the company contains N departments and the ith department is led by the ith staff. All subordinates of the ith staff are also belong to the ith department.
Last week, we hire a spy stealing into ICPC to get some information about salaries of staffs. Not getting the detail about each one, the spy only gets some information about some departments: the sum of the salaries of staff s working for the ith department is less than (more than or equal to) w. Although the some inaccurate information, we can also get some important intelligence from it.
Now I only concerned about whether the spy is telling a lie to us, that is to say, there will be some conflicts in the information. So I invite you, the talented programmer, to help me check the correction of the information. Pay attention, my dear friend, each staff of ICPC will always get a salary even if it just 1 dollar!
Input
There are multiple test cases.
The first line is an integer N. (1 <= N <= 10,000)
Each line i from 2 to N lines contains an integer x indicating the xth staff is the ith staff's superior(x<i).
The next line contains an integer M indicating the number of information from spy. (1 <= M <= 10,000)
The next M lines have the form like (x < (> or =) w), indicating the sum of the xth department is less than(more than or equal to) w (1 <= w <=100,000,000)
The first line is an integer N. (1 <= N <= 10,000)
Each line i from 2 to N lines contains an integer x indicating the xth staff is the ith staff's superior(x<i).
The next line contains an integer M indicating the number of information from spy. (1 <= M <= 10,000)
The next M lines have the form like (x < (> or =) w), indicating the sum of the xth department is less than(more than or equal to) w (1 <= w <=100,000,000)
Output
For each test case, output "True" if the information has no confliction; otherwise output "Lie".
Sample Input
5 1 1 3 3 3 1 < 6 3 = 4 2 = 2 5 1 1 3 3 3 1 > 5 3 = 4 2 = 2
Sample Output
Lie True
开始读错题了,以为是拓扑排序,
‘>','<','='号后的是金额,上司的工资大于下属的工资之和,这样就可以用树形DP做了。不小心用了自增,自减,一直wa

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=10000+100;
#define inf (1LL << 40)
long long up[maxn],down[maxn];
vector<int> son[maxn];
bool ans;
bool dfs(int u)
{
long long low=0;
for(int i=0;i<son[u].size();i++)
{
int v=son[u][i];
// if(v==father)
// continue;
if(!dfs(v))
return false;
low+=down[v];
}
down[u]=max(down[u],low+1);
if(down[u]>up[u])
{
return false;
}
return true;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
int x;
for(int i=0;i<=n;i++)
{
son[i].clear();
down[i]=1;
up[i]=inf;
}
for(int i=2;i<=n;i++)
{
scanf("%d",&x);
son[x].push_back(i);
//son[i].push_back(x);
}
int y,m;
char s[10];
scanf("%d",&m);
ans=false;
while(m--)
{
scanf("%d%s%d",&x,s,&y);
if(s[0]=='<')
{
up[x]=min(up[x],(long long)(y-1));//不留意用了y--,一直wa
}
else if(s[0]=='>')
{
down[x]=max(down[x],(long long)(y+1));
}
else
{
up[x]=min(up[x],(long long)y);
down[x]=max(down[x],(long long)y);
}
}
//if(ans==false)
ans= dfs(1);
if(!ans)
printf("Lie\n");
else
printf("True\n");
}
return 0;
}