The Euler function
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4624 Accepted Submission(s): 1935
Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
Output
Output the result of (a)+ (a+1)+....+ (b)
Sample Input
3 100
Sample Output
3042
解题思路:欧拉函数打表,刚开始把打表放在while循环里面,超时了几次,
下次注意啊:把打表函数放在循环外执行!
#include<stdio.h>
#include<string.h>
#define MAX 3000001
long long a[MAX];
int m,n;
void oula()
{
int i,j;
memset(a,0,sizeof(a));
a[1]=1;
for(i=2;i<MAX;i++)
{
if(!a[i])
{
for(j=i;j<MAX;j+=i)
{
if(!a[j])
a[j]=j;
a[j]=a[j]/i*(i-1);
}
}
}
}
int main()
{
oula();
long long sum;
int m,n;
while(scanf("%d%d",&m,&n)!=EOF)
{
sum=0;
for(int i=m;i<=n;i++)
sum+=a[i];
printf("%lld\n",sum);
}
return 0;
}