Auxiliary Set----DFS思维题

Auxiliary Set

Time Limit: 9000/4500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1083    Accepted Submission(s): 340


Problem Description
Given a rooted tree with n vertices, some of the vertices are important.

An auxiliary set is a set containing vertices satisfying at least one of the two conditions:

It is an important vertex
It is the least common ancestor of two different important vertices.

You are given a tree with n vertices (1 is the root) and q queries.

Each query is a set of nodes which indicates the  unimportant vertices in the tree. Answer the size (i.e. number of vertices) of the auxiliary set for each query.
 

Input
The first line contains only one integer T ( T1000 ), which indicates the number of test cases.

For each test case, the first line contains two integers n ( 1n100000 ), q ( 0q100000 ).

In the following n -1 lines, the i-th line contains two integers  ui,vi(1ui,vin)  indicating there is an edge between  ui i and  vi  in the tree.

In the next q lines, the i-th line first comes with an integer  mi(1mi100000)  indicating the number of vertices in the query set.Then comes with mi different integers, indicating the nodes in the query set.

It is guaranteed that  qi=1mi100000 .

It is also guaranteed that the number of test cases in which  n1000   or  qi=1mi1000  is no more than 10.
 

Output
For each test case, first output one line "Case #x:", where x is the case number (starting from 1).

Then q lines follow, i-th line contains an integer indicating the size of the auxiliary set for each query. 
 

Sample Input
  
  
1 6 3 6 4 2 5 5 4 1 5 5 3 3 1 2 3 1 5 3 3 1 4
 

Sample Output
  
  
Case #1: 3 6 3
Hint
For the query {1,2, 3}: •node 4, 5, 6 are important nodes For the query {5}: •node 1,2, 3, 4, 6 are important nodes •node 5 is the lea of node 4 and node 3 For the query {3, 1,4}: • node 2, 5, 6 are important nodes
 

Source

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5927


好一个思维DFS,这个题竟然能用dfs做我都没有想到,今天的比赛,我都没有看到这个题,放上大牛的链接,我从代码里讲吧。

http://blog.youkuaiyun.com/discreeter/article/details/52749361


代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N=100010;
struct node{
    int to,next;
}g[N*2];
int cnt,head[N];
int son[N],par[N],d[N],deep[N],tmp[N];
bool vis[N];
int n,m;
void connect(int v,int u){//前向星存图
    g[cnt].to=u;
    g[cnt].next=head[v];
    head[v]=cnt++;
}
void dfs(int v,int fa,int d){//一遍dfs求出父节点,儿子节点和深度
    vis[v]=true;
    par[v]=fa;
    deep[v]=d;
    for(int i=head[v];~i;i=g[i].next){
        int u=g[i].to;
        if(!vis[u])
            dfs(u,v,d+1),son[v]++;
    }
}
bool cmp(int a,int b){//按深度排序
    return deep[a]>deep[b];
}
int main(){
    int t;
    scanf("%d",&t);
    int ans=0;
    while(t--){
        ans++;
        cnt=0;
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){//初始化
            vis[i]=false;
            head[i]=-1;
            son[i]=0;
        }
        for(int i=1;i<n;i++){
            int u,v;
            scanf("%d%d",&v,&u);
            connect(u,v);
            connect(v,u);
        }
        dfs(1,-1,1);
        printf("Case #%d:\n",ans);
        while(m--){
            int k;
            scanf("%d",&k);
            int sum=n-k;//最开始有这么多重要节点
            for(int i=1;i<=k;i++){
                scanf("%d",&d[i]);
                tmp[d[i]]=son[d[i]];//复制
            }
            sort(d+1,d+1+k,cmp);//按深度排序
            for(int i=1;i<=k;i++){
                if(tmp[d[i]]>=2)//大牛讲的很清楚这里
                    sum++;
                else if(tmp[d[i]]==0)//因为是从最深开始的,所有最深的那个不重要节点下面肯定全都是重要的节点
                    tmp[par[d[i]]]--;
            }
            cout<<sum<<endl;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值