PAT 1001. A+B Format (20)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

思路:先存储两数的相加结果,判断正负,负输出‘-’,然后把结果转化为正数统一运算。在这里有三种可能,结果小于1000直接输出,结果介于1000和1000000之间的,中间要有‘,’隔开,这可以用取余和除于1000来分别输出逗号两边的数,类似的最后一种情况也这样做。
 
#include <cstdio>

int main()
{
	int a, b, c;
	while (scanf("%d %d", &a, &b) != EOF)
	{
		c = a + b;
		if (c < 0) {   //先输出负数符号,把负数转换为正数,方便下面输出
			printf("-");
			c = -c;
		}
		if (c <1000)
			printf("%d\n", c);
		else if (c < 1000000)
		        printf("%d,%03d\n", c/1000, c%1000);
		     else
		        printf("%d,%03d,%03d\n",c/1000000, (c % 1000000) / 1000, c%1000 );
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值