B - How many integers can you find 杭电1976

本文解决了一个复杂的数学问题,即在给定的范围内找到能被特定集合中所有整数整除的数的数量。通过使用位运算和最小公倍数的概念,算法有效地计算了满足条件的整数数量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

 Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.Output  For each case, output the number.Sample Input

12 2
2 3

Sample Output

7
被这个题卡了很久,主要是有个坑和一个一个知识漏洞
题目最欧一句话描述的不太清晰,,他的意思是输入的M的整数中可能有0;
还有就是判断一个数在n前面的数中充当因子的次数时,可以直接用n除以这个数,但是判断多个数时,共同充当因子的次数时,要用n除以这几个数的最小公倍数

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<set>
using namespace std;
typedef long long ll;
ll arr[100];
//set<ll>se;
//set<ll>::iterator it;
int main(){
    ll n,m; 
    while(scanf("%lld%lld",&n,&m)!=EOF)
    {
        ll x,pos=0;
        for(int i=1;i<=m;i++){
            scanf("%lld",&x);
            if(x!=0){
//                se.insert(x);
                pos++;
                arr[pos]=x;
            }
        }
//        
//        ll pos=0;
//        for(it=se.begin();it!=se.end();it++){
//            pos++;
//            arr[pos]=*it;
//        }
//        
        
        ll s=0;
        for(int i=1;i<(1<<pos);i++){
            ll cnt =0,sum=1;
            for(int j=0;j<pos;j++){
                if(1&(i>>j)){
//                    sum*=arr[j+1];
                    sum=(sum*arr[j+1])/__gcd(sum,arr[j+1]);
                    cnt++;
                }
            }
            if(cnt&1){
                s+=n/sum;
            } 
            else {
                s-=n/sum;
            }
        }
        for(int i=1;i<=pos;i++)
            if(n%arr[i]==0){
                s--;
                break;
            }
        printf("%lld\n",s);
//        se.clear();
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Accepting/p/11358150.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值