poj 1742 Coins

Coins

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 48194 Accepted: 16209

Description

  People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
  You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

  The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

   For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题意:有n种钱币,每种有个,价值为,求这些钱币能凑出多少种小于等于m的金额。

题解:男人八题之一怎么可能用直接的多重背包就能解决。此题数据范围较大,多重背包会TLE。dp[i]不应该记录容量为i的背包最多能装多少,而应该记录是否能达到容量i。

代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn=100005;
int num[maxn],w[maxn],flag[maxn],cnt[maxn];
int main()
{
   int i,j,n,m,ans;
   while(~scanf("%d%d",&n,&m))
   {
    if(!n&&!m) break;
    {
     fill(flag,flag+maxn,0);
     flag[0]=1;
     ans=0;
    }
    for(i=1;i<=n;i++) scanf("%d",&w[i]);
    for(i=1;i<=n;i++) scanf("%d",&num[i]);
    for(i=1;i<=n;i++)
    {
     fill(cnt,cnt+maxn,0);
     for(j=w[i];j<=m;j++)
       if(!flag[j]&&flag[j-w[i]]&&cnt[j-w[i]]+1<=num[i])
        {
          ans++;
          flag[j]=1;
          cnt[j]=cnt[j-w[i]]+1;
        }
    }
    printf("%d\n",ans);
   }
   return 0;
}

转载于:https://www.cnblogs.com/VividBinGo/p/11359071.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值