[PAT A1093 1093 Count PAT‘s]

[PAT A1093 1093 Count PAT's]

 

Description:

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

CODE 

算法1:

暴力求解,三个for循环,时间复杂度为N的三次方

#include <cstdio>
#include <cstring>
const int maxn=1000000000;
char buffer[maxn];
 int main(){
     scanf("%s",buffer);
     int len=strlen(buffer);
     long long cnt=0;
     for(int i=0;i<len;i++){
         if(buffer[i]!='P')
             continue;
         for(int j=i+1;j<len;j++){
            if(buffer[j]!='A')
                continue;
             for(int k=j+1;k<len;k++){
                if(buffer[k]=='T'){
                cnt++;
                cnt=cnt%1000000007;
                }
             }
         }
     }
     printf("%lld",cnt);
     return 0;
 }

超时:

 

算法2:

考虑PAT三个字符,在一个串中,若当前字符为A,那么此时可能的PAT组合数为:当前位置左边的P个数*当前位置右边T的个数,虽然仍有三个for循环,但内部的两个总共遍历一次,时间复杂度为N的二次方

#include <cstdio>
#include <cstring>
const int maxn=1000000000;
char buffer[maxn];
 int main(){
     scanf("%s",buffer);
     int len=strlen(buffer);
     long long cnt=0;
     for(int i=0;i<len;i++){
         if(buffer[i]=='A'){
             int cntp=0,cntt=0;
             for(int j=0;j<i;j++){
                 if(buffer[j]=='P')
                     cntp++;
             }
             if(cntp==0)continue;
             for(int j=i+1;j<len;j++){
                 if(buffer[j]=='T')
                     cntt++;
             }
             if(cntt==0)continue;
             cnt+=cntp*cntt;
             cnt=cnt%1000000007;
         }
     }
     printf("%lld",cnt);
     return 0;
 }

依旧超时:

算法三:

考虑在算法二的基础上,使用一个数组存储各个字符A左边字符P的个数;然后再从尾到头得到A右边T的个数,同时计数。

#include <cstdio>
#include <cstring>
const int maxn=100001;
char buffer[maxn];
int cntp[maxn]={0};
int cntt=0;

 int main(){
     scanf("%s",buffer);
     int len=strlen(buffer);
     long long cnt=0;
     for(int i=0;i<len;i++){
         if(buffer[i]=='P'){
             if(i==0)
                 cntp[0]=1;
             else
                 buffer[i]=buffer[i-1]+1;
         }else{
             if(i==0)
                 buffer[0]=0;
             else
                 buffer[i]=buffer[i-1];
         }
     }
     for(int j=len-1;j>0;j--){
         if(buffer[j]=='T'){
             cntt++;
             continue;
         }
         if(buffer[j]=='A'){
             cnt+=cntp[j]*cntt;
             cnt=cnt%1000000007;
         }
     }
     printf("%lld",cnt);
     return 0;
 }

结果OK:

 

易错点:

以上优化思想来自算法笔记:

1.这个换个角度看A左边有多少个P,右边有多少个T确实厉害

2.用空间换时间,提前记录好P的个数(打表思想)

 

 

内容概要:《2024年中国城市低空经济发展指数报告》由36氪研究院发布,指出低空经济作为新质生产力的代表,已成为中国经济新的增长点。报告从发展环境、资金投入、创新能力、基础支撑和发展成效五个维度构建了综合指数评价体系,评估了全国重点城市的低空经济发展状况。北京和深圳在总指数中名列前茅,分别以91.26和84.53的得分领先,展现出强大的资金投入、创新能力和基础支撑。低空经济主要涉及无人机、eVTOL(电动垂直起降飞行器)和直升机等产品,广泛应用于农业、物流、交通、应急救援等领域。政策支持、市场需求和技术进步共同推动了低空经济的快速发展,预计到2026年市场规模将突破万亿元。 适用人群:对低空经济发展感兴趣的政策制定者、投资者、企业和研究人员。 使用场景及目标:①了解低空经济的定义、分类和发展驱动力;②掌握低空经济的主要应用场景和市场规模预测;③评估各城市在低空经济发展中的表现和潜力;④为政策制定、投资决策和企业发展提供参考依据。 其他说明:报告强调了政策监管、产业生态建设和区域融合错位的重要性,提出了加强法律法规建设、人才储备和基础设施建设等建议。低空经济正加速向网络化、智能化、规模化和集聚化方向发展,各地应找准自身比较优势,实现差异化发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值