[PAT A1025 PAT Ranking]
Description:
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
Code
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
typedef struct Grade{
char register_no[20];
int grade;
int final_rank;
int local_number;
int local_rank;
}Grade;
Grade grade_list[30000];
bool cmp1(Grade a,Grade b){
return a.grade>b.grade;
}
bool cmp2(Grade a,Grade b){
if(a.grade!=b.grade)return a.grade > b.grade;
else return strcmp(a.register_no,b.register_no)<0;
}
int main(){
int n,k,cnt=0;
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%d",&k);
for(int j=0;j<k;j++){
scanf("%s %d",grade_list[cnt].register_no,&grade_list[cnt].grade);
grade_list[cnt].local_number=i+1;
cnt++;
}
//先按照本地成绩排序
sort(grade_list+cnt-k,grade_list+cnt,cmp1);
//为local_rank赋值,注意需要同样成绩的排名相同
grade_list[cnt-k].local_rank=1;
for(int l=cnt-k+1;l<cnt;l++){
if(grade_list[l].grade == grade_list[l-1].grade){
grade_list[l].local_rank=grade_list[l-1].local_rank;
}else{
grade_list[l].local_rank=l-(cnt-k)+1;
}
}
}
//按照总成绩排序
sort(grade_list,grade_list+cnt,cmp2);
printf("%d\n",cnt);
//为final_rank赋值,注意需要同样成绩的排名相同
grade_list[0].final_rank=1;
for(int i=0;i<cnt;i++){
if(i!=0){
if(grade_list[i].grade == grade_list[i-1].grade){
grade_list[i].final_rank=grade_list[i-1].final_rank;
}else{
grade_list[i].final_rank=i+1;
}
}
printf("%s %d %d %d\n",grade_list[i].register_no,grade_list[i].final_rank,grade_list[i].local_number,grade_list[i].local_rank);
}
return 0;
}
注意:
1)排序中的两种cmp的写法
2)在成绩相同时,排名相同的处理:需要和前一个排名的成绩做对比,若不同,再从下标取值+1.