[LIS_最长递增子序列]-hdu 1003 Max Sum

本篇介绍一道经典编程题目——给定一个整数序列,找出该序列中具有最大和的连续子序列及其起始和结束位置,并提供详细的解题思路与AC代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

[LIS_最长递增子序列]-hdu 1003 Max Sum

标签(空格分隔): ACM

题意:

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

sample input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

sample output

Case 1:
14 1 4

Case 2:
7 1 6

解题思路:

状态转移方程为:dp[i]=max(dp[i-1]+a[i],a[i])

AC代码:

#include <iostream>
#include <stdio.h>
#define MAX 1000005
using namespace std;

int t,n;
int a[MAX];
int dp[MAX];
int main()
{
    scanf("%d",&t);
    for(int x=1;x<=t;x++)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        dp[1]=a[1];
        for(int i=2;i<=n;i++)
        {
            if(dp[i-1]<0)
                dp[i]=a[i];
            else
                dp[i]=dp[i-1]+a[i];
        }
        int maxs=dp[1];
        int l=1,r=1;
        for(int i=1;i<=n;i++)
        {
            if(dp[i]>maxs)
            {
                maxs=dp[i];
                r=i;
            }
        }
        for(int i=r;i>=1;i--)
        {
            if(dp[i]<0)
            {
                l=i+1;
                break;
            }
        }
        if(l>r)l=r;
        printf("Case %d:\n%d %d %d\n",x,maxs,l,r);
        if(x!=t)
            printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值