[LIS_最长递增子序列]-hdu 1003 Max Sum
标签(空格分隔): ACM
题意:
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
sample input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
sample output
Case 1:
14 1 4Case 2:
7 1 6
解题思路:
状态转移方程为:dp[i]=max(dp[i-1]+a[i],a[i])
AC代码:
#include <iostream>
#include <stdio.h>
#define MAX 1000005
using namespace std;
int t,n;
int a[MAX];
int dp[MAX];
int main()
{
scanf("%d",&t);
for(int x=1;x<=t;x++)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
dp[1]=a[1];
for(int i=2;i<=n;i++)
{
if(dp[i-1]<0)
dp[i]=a[i];
else
dp[i]=dp[i-1]+a[i];
}
int maxs=dp[1];
int l=1,r=1;
for(int i=1;i<=n;i++)
{
if(dp[i]>maxs)
{
maxs=dp[i];
r=i;
}
}
for(int i=r;i>=1;i--)
{
if(dp[i]<0)
{
l=i+1;
break;
}
}
if(l>r)l=r;
printf("Case %d:\n%d %d %d\n",x,maxs,l,r);
if(x!=t)
printf("\n");
}
return 0;
}