pat1133 Splitting A Linked List (静态链表 vector)

1133 Splitting A Linked List (25 分)

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤103). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−105,105], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

题意: 给出一个静态链表,按照所给要求排序:

1、小于0的按照链表中出现顺序,排在前面

2、大于等于0且小于等于k的,按照原出现顺序,排在中间

3、大于k的按照原出现顺序,排在最后。

思路:建立三个vector向量,分别储存要求1、2、3的数,最后合并,在输出就可以了。

反思:刚开始没想到vector合并,先输出向量1,在输出2,最后3,结果出现了段错误,代码还很冗长。一合并就好了。

vector合并:

vector<string>vec1,vec2,vec3;
//... vec1,vec2赋值
vec3.insert(vec3.end(),vec1.begin(),vec1.end());
vec3.insert(vec3.end(),vec2.begin(),vec2.end()); 
#include <iostream>
#include "vector"
using namespace std;
struct node{
    int address;
    int data;
    int next;
    int index;
}Node[100100];
vector<node> ans,ans1,ans2;
int start,n,k;
int main() {
    cin>>start>>n>>k;
    for (int i = 0; i < n; ++i) {
        int a,b,c;
        cin>>a>>b>>c;
        Node[a]={a,b,c};
    }
    int flag=1;
    while (flag){
        if (Node[start].data<0){
            ans.push_back(Node[start]);
        } else if (Node[start].data>=0 && Node[start].data<=k){
            ans1.push_back(Node[start]);
        } else {
            ans2.push_back(Node[start]);
        }
        if (Node[start].next==-1) break;
        start=Node[start].next;
    }
    ans.insert(ans.end(),ans1.begin(),ans1.end());
    ans.insert(ans.end(),ans2.begin(),ans2.end());
    for (int i = 0; i < ans.size()-1; ++i) {
        ans[i].next=ans[i+1].address;
    }
    ans[ans.size()-1].next=-1;
    for (int i = 0; i < ans.size(); ++i) {
        if (i!=ans.size()-1)printf("%05d %d %05d\n",ans[i].address,ans[i].data,ans[i].next);
        else printf("%05d %d -1\n",ans[i].address,ans[i].data,ans[i].next);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值