a1013 Battle Over Cities (图的遍历 DFS)

该博客介绍了一个关于战时城市连接问题的算法,当城市被占领时,需要确定需要修复哪些道路以保持其余城市的连通。算法通过输入城市数量、剩余道路数和待检查城市,计算并输出每个城市丢失后需要修复的道路数。示例展示了3个城市和2条道路的情况,当城市1被占领时,需要修复1条道路。解决方案包括深度优先搜索(DFS)来标记和计算连通块。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​-city2​ and city1​-city3​. Then if city1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​-city3​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

思路:算出删除查询节点后还有多少的连通块,最后的结果就是连通块数目-1。

dfs:标记每个节点及其可到达的节点为已访问,当为该节点为待查询节点时,就return。

查询:当节点不是带查询节点、并且该节点未被访问过(有可能在之前的DFS标记中已被标记访问过),就进行DFS块标记。

#include <iostream>
#include "algorithm"
using namespace std;
const int maxx = 1100,INF=10000000;
int n,m,k,nums,query;
int G[maxx][maxx];
bool vis[maxx];
void DFS(int u){
    if (u == query) return;
    vis[u] = true;
    for (int i = 1; i <= n; ++i) {
        if (!vis[i] && G[u][i] < INF){
            DFS(i);
        }
    }
}
int main() {
    cin>>n>>m>>k;
    int a,b;
    fill(G[0],G[0]+maxx*maxx,INF);
    for (int i = 0; i < m; ++i) {
        cin>>a>>b;
        G[a][b]=G[b][a] = 0;
    }
    for (int i = 0; i < k; ++i) {
        cin>>query;
        fill(vis,vis+maxx,0);
        int block=0;
        for (int j = 1; j <= n; ++j) {
            if (j != query && !vis[j]) {
                DFS(j);
                block++;
            }
        }
        cout<<block-1<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值