poj 2421 Constructing Roads(最小生成树)

Constructing Roads
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 22124 Accepted: 9431

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179
题意:给一个初始图,再给 m条边,a,b表明a和b不需要花费时间可以直接到达,问最小生成树是多少

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 150
#define INF 99999999
int ma[N][N];
long long d[N],vis[N];
int n;
long long prim(int s)
{
    for(int i=1; i<=n; i++)
        d[i]=i==s?0:ma[s][i];
    vis[s]=1;
    long long ans=0;
    for(int i=1; i<n; i++)
    {
        int maxn=INF,v;
        for(int j=1; j<=n; j++)
            if(!vis[j]&&maxn>d[j])
            {
                maxn=d[j];
                v=j;
            }
        vis[v]=1;
        ans+=maxn;
        for(int j=1; j<=n; j++)
            if(!vis[j]&&ma[v][j]<d[j])
                d[j]=ma[v][j];
    }
    return ans;
}
int main()
{
    int m;
    int s,e;
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof(vis));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                scanf("%d",&ma[i][j]);
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d %d",&s,&e);
            ma[s][e]=0;
            ma[e][s]=0;
        }
        long long ans=prim(1);
        printf("%lld\n",ans);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值