Largest prime factor
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 10043 Accepted Submission(s): 3552
Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
Input
Each line will contain one integer n(0 < n < 1000000).
Output
Output the LPF(n).
Sample Input
1 2 3 4 5
Sample Output
0 1 2 1 3
思路:用素数筛选可以求出每个素数的位置,再求出最大质因数,O(1)就可以做到查找了
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
#define N 1000010
int prime[N],notprime[N];
void init()
{
memset(notprime,0,sizeof(notprime));
prime[0]=0;prime[1]=0;
for(int i=2;i<N;i++)
{
if(!notprime[i])
{
prime[i]=++prime[0];
for(long long j=(long long)i*i;j<N;j+=i)
notprime[j]=1;
}
}
}
int Devie(int n)
{
int maxn=-1;
for(int i=2;i*i<=n;i++)
{
if(n%i==0)
{
if(maxn<i) maxn=i;
while(n%i==0)
n/=i;
}
}
if(n>1) return max(maxn,n);
return maxn;
}
int main()
{
int n;
init();
while(~scanf("%d",&n))
{
if(n==1) printf("0\n");
else
{
int m=Devie(n);
printf("%d\n",prime[m]);
}
}
return 0;
}