C语言合法标识符
Problem Description 输入一个字符串,判断其是否是C的合法标识符。
Input 输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
Output 对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
Sample Input 3 12ajf fi8x_a ff ai_2
Sample Output no yes n0 |
代码如下:
#include <stdio.h>
#include <stdlib.h>
int main(int argc, char *argv[])
{
int n;
char tmp[50];
int i, j, flag, f;
while(scanf("%d", &n) != EOF)
{
getchar(); //清除键盘缓存 读掉滞留在缓存区的回车
for(i=0; i<n; i++)
{
flag = 0;
f = 0;
j=0;
scanf("%[^\n]", &tmp);///
ge