Intersecting Lines
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 11264 | Accepted: 5083 |
Description
We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.
Input
The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
Output
There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".
Sample Input
5 0 0 4 4 0 4 4 0 5 0 7 6 1 0 2 3 5 0 7 6 3 -6 4 -3 2 0 2 27 1 5 18 5 0 3 4 0 1 2 2 5
Sample Output
INTERSECTING LINES OUTPUT POINT 2.00 2.00 NONE LINE POINT 2.00 5.00 POINT 1.07 2.20 END OF OUTPUT
Source
#include<stdio.h>
#include<math.h>
const double epsi=1e-10;
inline int sign(const double &x);
inline double sqr(const double &x);
struct Point{
double x,y;
Point(double _x=0,double _y=0):x(_x),y(_y){
}
Point operator +(const Point &op2) const{
return Point(x+op2.x,y+op2.y);
}
Point operator -(const Point &op2) const{
return Point(x-op2.x,y-op2.y);
}
double operator ^(const Point &op2) const{
return x*op2.y-y*op2.x;
}
double operator *(const Point &op2) const{
return x*op2.x+y*op2.y;
}
Point operator *(const double &d) const{
return Point(x*d,y*d);
}
Point operator /(const double &d) const{
return Point(x/d,y/d);
}
bool operator ==(const Point &op2) const{
return sign(x-op2.x)==0&&sign(y-op2.y)==0;
}
};
inline int sign(const double &x){
if(x>epsi) return 1;
if(x<-epsi) return -1;
return 0;
}
inline double mul(const Point &p0,const Point &p1,const Point &p2){//p0p1与p0p2叉积
return (p1-p0)^(p2-p0);
}
inline double sqr(const double &x){
return x*x;
}
inline double dis2(const Point &p0,const Point &p1){//p0p1平方
return sqr(p0.x-p1.x)+sqr(p0.y-p1.y);
}
inline double dis(const Point &p0,const Point &p1){//p0p1
return sqrt(dis2(p0,p1));
}
inline int cross(const Point &p1,const Point &p2,const Point &p3,const Point &p4){//求p1p2,p3p4是否跨立
int sign1=sign(mul(p1,p3,p2));//求p1p3和p1p2叉积,
int sign2=sign(mul(p1,p4,p2));//求p1p4和p1p2叉积,
if(sign1==0&&sign2==0) return 2;//p3或p4在p1p2上
if(sign1==sign2) return 0;//不跨立
return 1;
}
inline int cross(const Point &p1,const Point &p2,const Point &p3,const Point &p4,Point &p){//求p1p2,p3p4,是否跨立,如果相交则求出交点
double a1=mul(p1,p2,p3);
double a2=mul(p1,p2,p4);
if(sign(a1)==0&&sign(a2)==0) return 2;//p3p4在p1p2上
if(sign(a1-a2)==0) return 0;//,无交点
p.x=(a2*p3.x-a1*p4.x)/(a2-a1);
p.y=(a2*p3.y-a1*p4.y)/(a2-a1);
return 1;
}
Point p1,p2,p3,p4,p;
int main(){
int N;
scanf("%d",&N);
printf("INTERSECTING LINES OUTPUT\n");
while(N--){
scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&p1.x,&p1.y,&p2.x,&p2.y,&p3.x,&p3.y,&p4.x,&p4.y);
// printf("~~~~%lf %lf %lf %lf %lf %lf %lf %lf~~~\n",p1.x,p1.y,p2.x,p2.y,p3.x,p3.y,p4.x,p4.y);
int fla=cross(p1,p2,p3,p4,p);
switch(fla){
case 0:
printf("NONE\n");
break;
case 1:
printf("POINT %.2lf %.2lf\n",p.x,p.y);
break;
case 2:
printf("LINE\n");
break;
default:
break;
}
}
printf("END OF OUTPUT\n");
return 0;
}