沈阳师范大学-PTA-数据结构-单链表的创建及遍历

本文介绍了一个简单的单链表实现方法,包括如何通过读取输入数据来创建单链表,并实现遍历输出的功能。文章提供了一段C++代码示例,展示了从输入获取节点数据、构建链表以及打印链表内容的过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

7-6 单链表的创建及遍历 (20分)
读入n值及n个整数,建立单链表并遍历输出。

输入格式:
读入n及n个整数。

输出格式:
输出n个整数,以空格分隔(最后一个数的后面没有空格)。

输入样例:
在这里给出一组输入。例如:

2
10 5
输出样例:
在这里给出相应的输出。例如:

10 5

#include<iostream>
#include<cstdio>
typedef struct MyNode* NodePoint;
struct MyNode
{
    int data;
    NodePoint link;
};
void CreateNode(int NodeData, NodePoint* PRear) {
    NodePoint P;
    P = (NodePoint)malloc(sizeof(struct MyNode));
    P->data = NodeData;
    P->link = NULL;
    (*PRear)->link = P;
    *(PRear) = P;
}
NodePoint ReadNode() {
    int NodeNum, NodeData,PonitNum=0;
    NodePoint P, Rear, Temp;
    std::cin >> PonitNum;
    P = (NodePoint)malloc(sizeof(struct MyNode));
    P->link = NULL;
    Rear = P;
    for(int i=0;i<PonitNum;i++){
        std::cin>>NodeData;
        CreateNode(NodeData,&Rear);
    }
    Temp = P;
    P = P->link;
    free(Temp);
    //std::cout << "Done" << "\n";
    return P;
}
void NodeAdd1(NodePoint P1, NodePoint P2) {
    if(P1==NULL&&P2==NULL){
        std::cout<<"NULL"<<"\n";
    }
    NodePoint P, P0;
    P = (NodePoint)malloc(sizeof(struct MyNode));
    P0 = P;
    while (P1 && P2) {
        if (P1->data <= P2->data) {
            P0->link = P1;
            P0 = P1;
            //std::cout << P0->data << "\n";
            P1 = P1->link;
        }
        else {
            P0->link = P2;
            P0 = P2;
            //std::cout << P0->data << "\n";
            P2 = P2->link;
        }
    }
    P0->link = P1 ? P1 : P2;
    //P0->link = NULL;
    P = P->link;
    if(P) {
        std::cout << P->data;
        P = P->link;
    }
    while (P) {
        std::cout << " " << P->data ;
        P = P->link;
    }
}
void NodeOut(NodePoint P) {
    if(P==NULL){
        std::cout<<"";
        return;
    }
    int stats=0;
    while (P) {
        if(stats==0){
            std::cout<<P->data;
            stats=1;
        } else{
            std::cout<<" "<<P->data;
        }
        P=P->link;
    }
}
int main() {
    NodePoint P1, P2, P3;
    P1 = ReadNode();
    //P2 = ReadNode();
   // NodeAdd1(P1, P2);
    //NodeOut(P1);
    NodeOut(P1);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值