There is a very simple and interesting one-person game. You have 3 dice, namely Die1, Die2 and Die3. Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:
- Set the counter to 0 at first.
- Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
- If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.
Calculate the expectation of the number of times that you cast dice before the end of the game.
Input
There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0 <= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).
Output
For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.
Sample Input
2 0 2 2 2 1 1 1 0 6 6 6 1 1 1
Sample Output
1.142857142857143 1.004651162790698
题意:给出3颗骰子,分别有k1,k2,k3面,能到的点数都是1~k1、k2、k3。同时摇3颗骰子,当三颗骰子分别达到a,b,c的时候分数置为0,否则当前分数加上三颗骰子值的总和。问从0开始到大于n所需的步数期望
思路:设E[i]表示到达分数i的时候,接下来需要投掷的步数期望
因为n>0时停止投掷,E[n>0]=0,所以E[0]就是所要算的期望(为何E[0]就是所要算的我也没搞明白)
E[i]=∑pk(E[i+k]+1)+p0*(E[0]+1)=∑pk(E[i+k])+p0*(E[0])+1
即比下一个状态多走一步,由下一步每个状态的期望乘以到达那步的概率求和得到当前
由于每一步都要涉及到E[0],所以我们可以把它当成一个未知数来求
设E[i]=a[i]*E[0]+b[i],则E[i+k]=a[i+k]*E[0]+b[i+k]代入上式后,化简得
E[i]=(∑pk*a[i+k]+p0)*E[0]+(∑pk*b[i+k]+1)
所以:a[i]=∑pk*a[i+k]+p0b[i]=∑pk*b[i+k]+1
因为E[n>k]=0,所以a[i+k],b[i+k]都等于0,因为它们只能为正数
这样就能推出n到0所有的a[i]跟b[i]
E[0]=a[0]*E[0]+b[0]
所以(1-a[0])*E[0]=b[0],即E[0]=b[0]/(1-a[0])
#include<cstdio>
#include<cstring>
double p[40];
double a[550],b[550];
int main(void){
int n,k1,k2,k3,x,y,z,t;
double q;
double ks;
scanf("%d",&t);
while(t--){
scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&x,&y,&z);
memset(p,0,sizeof(p));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
q=1.0/(k1*k2*k3);
for(int i=1;i<=k1;i++)
for(int j=1;j<=k2;j++)
for(int k=1;k<=k3;k++)
if(i==x&&j==y&&k==z)
continue;
else p[i+j+k]+=q;
for(int i=n;i>=0;i--){//这里等同于下面的注释
for(int k=3;k<=k1+k2+k3;k++)
a[i]+=p[k]*a[i+k],b[i]+=p[k]*(b[i+k]+1);
a[i]+=q,b[i]+=q;//主要是b[i]+=q是把p0加上
}
/*
for(int i=n;i>=0;i--){
for(int k=3;k<=k1+k2+k3;k++)
a[i]+=p[k]*a[i+k],b[i]+=p[k]*b[i+k];
a[i]+=q,b[i]+=1;
}
*/
printf("%.10f\n",b[0]/(1-a[0]));
}
return 0;
}