Description

Ultra-QuickSort produces the output
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5 9 1 0 5 4 3 1 2 3 0
Sample Output
60
比较坑,输出既然要用longlong才能过
#include <cstdio>
using namespace std;
int A[500008],AA[500008];
long long int sum;
void merge_sort(int *A,int x,int y,int *T)
{
if(y-x>=1)
{
int m=x+(y-x)/2;
int p=x,q=m+1,i=x;
merge_sort(A,x,m,T);
merge_sort(A,m+1,y,T);
while(p<=m||q<=y)
{
if(q>y||(p<=m&&A[p]<=A[q]))
{
T[i++]=A[p++];
}
else
{
T[i++]=A[q++];
sum+=q-i;
}
}
for(int i=x;i<=y;i++)
{
A[i]=T[i];
}
}
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n)
{
sum=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&A[i]);
}
merge_sort(A,1,n,AA);
printf("%lld\n",sum);
}
return 0;
}