Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
/*
1: 0 0 空树是一棵树
2: 1 1 0 0 不是树 不能自己指向自己
3: 1 2 1 2 0 0 不是树....自己开始一直在这么WA 好郁闷 重复都不行呀~~5555
4: 1 2 2 3 4 5 不是树 森林不算是树(主要是注意自己)
5: 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 1 注意 一个节点在指向自己的父亲或祖先 都是错误的 即 9-->1 错
6: 1 2 2 1 0 0 也是错误的
每次输入u v
判断u v 是否相同,v是否有不是v的父亲。这样都是不行的
如果v那边没问题,就得考虑u能不能做v的父亲,如果v曾经是u的祖宗,那就肯定不行,也就是有环
*/
#include <iostream>
#include <cstdio>
using namespace std;
int father[15];
int A[15];
int find(int x)
{
if(x==father[x])return x;
return find(father[x]);
}
int main()
{
int u,v;
int t=0;
while(scanf("%d%d",&u,&v)==2&&(u!=-1))
{
t++;
int m=0;
for(int i=0;i<=14;i++)
{
father[i]=i;
}
bool flag=true;
while(u||v)
{
if(!flag)goto L;
if(u==v)
{
flag=false;
goto L;
}
A[m++]=u;A[m++]=v;
if(father[v]!=v)
{
flag=false;
goto L;
}
if(father[v]==v)
{
bool ok=true;
int k=u;
while(father[k]!=k)
{
if(k==v)
{
ok=false;
break;
}
k=father[k];
}
if(father[k]==v)ok=false;
if(!ok)flag=false;
else father[v]=u;
}
L:
scanf("%d%d",&u,&v);
}
int zuzong;
if(!flag)goto LL;
zuzong=find(A[0]);
for(int i=0;i<m;i++)
{
if(find(A[i])!=zuzong)
{
flag=false;
break;
}
}
LL:
if(flag)printf("Case %d is a tree.\n",t);
else printf("Case %d is not a tree.\n",t);
}
return 0;
}