Running Median
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5191 Accepted: 2309
Description
For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.
Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.
Output
For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.
Sample Input
3
1 9
1 2 3 4 5 6 7 8 9
2 9
9 8 7 6 5 4 3 2 1
3 23
23 41 13 22 -3 24 -31 -11 -8 -7
3 5 103 211 -311 -45 -67 -73 -81 -99
-33 24 56
Sample Output
1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3
-7 -3
Source
Greater New York Regional 2009
题目大意:
读入奇数个数时打印出当前中位数
题目思路:
利用一个大顶堆和一个小顶堆来维护中位数, 我们依次将数据存入小顶堆和大顶堆(将第一个数存入小顶堆, 第二个数存入大顶堆, 第三个数存入小顶堆…), 每次都维护小顶堆的顶端元素使其大于大顶堆的顶端元素,使得小顶堆的元素都大于大顶堆的元素, 那么小顶堆的顶端元素就是存入奇数个数时的中位数。
AC代码
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
int main()
{
int t;
cin >> t;
while (t--) {
priority_queue<int, vector<int>, greater<int> > gq;
priority_queue<int> lq;
int n, m, count = 0;
cin >> n >> m;
cout << n <<" "<< (m + 1) / 2 << endl;
int x;
for (int i = 1; i <= m; ++i) {
cin >> x;
if (i % 2) {
gq.push(x);
}
else {
lq.push(x);
}
while (!lq.empty() && lq.top() > gq.top()) {
int t1 = lq.top();
int t2 = gq.top();
lq.pop(); gq.pop();
lq.push(t2); gq.push(t1);
}
if (i % 2) {
cout << gq.top();
count++;
if (count % 10 == 0) {
cout << endl;
}
else if (i != m - 1 && i != m) {
cout << " ";
}
else if (i == m) {
cout << endl;
}
}
}
}
return 0;
}